[BUG] Carpenter Promotion Animation Repeats Itself


#1

I have found another amusing bug in the newest version of Stonehearth Alpha

Also, this is a different bug than the last one I reported, which was somewhat similar to this one.

Bug :

The Animation for Premoting a Regular Worker Sometimes Repeats Itself a Couple of Times

Rarity:

Mildly Common

Severity:

Minor, yet annoying

Summary:

As soon as I picked out my Starting Point where my settlement would be, I created a Stockpile. As soon as I did that, my Settlers put down their Materials, with one of them being the saw. When they finished putting the Materials down, I clicked on the Saw and premoted a random Worker to Carpenter. He ran over o the saw to pick it up, but half way of picking the Saw up, it froze and the animation repeated itself. The game retried to sucessfully play the animation, but it froze again and repeated itself. It then froze again and instead of the animation repeating itself once more, the Worker picked the Saw up and moved it to a different location in the Stockpile. After putting it down, he picked it up and the animation started up again. Not suprisingly, the animation froze and repeated. The next time the animation started up again, it suceeded in premoting the regular Worker into a Carpenter. The game worked normally after that.

Steps to reproduce:

  1. Click on the Saw
  2. Click on a Regular Worker
  3. Let Him/Her run over to The Saw
  4. Let the Carpenter Premoting Animation start
  5. Now, there is a Small CHance that this Bug will happen, or something similar will happen

Expected Results:

I expected the animation to work normally, and for the regular Worker to be Premoted to Carpenter

Actual Results:

Like I discribed, the animation repeated itself a couple times, the worker picked up the Saw and moved it to a different location, the animation restarted, repeated itself, and finally worked the next time it happened.

Notes:

When the bug happened, an ingame error screen popped up in the top left corner several times.

Attachments:

I would’ve recorded it if I had my Recording Software, which is Bandicam, running at the moment, but I didn’t, and so I have no Attachments to show you. Sorry about that.

Versions and Mods:

I’m running Stonehearth Alpha Version r41 and I haven’t downloaded any 3rd party mods for the game at the moment.

System Information:

Microsoft Windows 8.1 64 Bit | Intel Inside CORE i7 | 8104 MB RAM | nVidia GeForce GT 755M


#2

He was not worthy of the saw!


#3

this would be most helpful! :smiley: