[Bug][1687] Broken Smods

Continuing the discussion from Nihonjin: Japanese Themed Mod [Download Now]:

Test 1: Just did a little testing. Tried zipping with an archiver and with the default “send to compressed folder” options and neither worked when turned into an smod. However one of the times I tried I forgot to turn the smod into a .zip and it worked.

I’m kind of thinking it has something to do with the renaming or a .zip file to a .smod

Test 2: Downloaded Candledark.smod. Stonehearth will not launch as .smod. Launches fine if run as .zip

Test 3: Completely deleted everything in my stonehearth folder and preformed a clean install. Still having the same issues.


2014-Oct-28 18:07:18.344355logger initialized
2014-Oct-28 18:07:18.363356 | server | 1 |                              app | Stonehearth Version
2014-Oct-28 18:07:18.428360 | server | 0 |                         lua.data | lua git is enabled
2014-Oct-28 18:07:18.431360 Fatal Exception.
2014-Oct-28 18:07:18.431360 Total System Memory: 7247028224
2014-Oct-28 18:07:18.431360 Current memory usage: 22683648

Windows 7 64bit


Thanks! What version of Stonehearth?

D1687 is the version i’m currently experiencing this with.

Hm, I know that candledark.smod works with version 150 (the regular branch) so maybe something broke in reading .smods in the time since then.

1 Like

I’m using version 1687 too and it’s the first one, where the .smod-files making problems. In the unstable versions before there were no problems with the loading of the .smod-files. Unzipped all the mods are working, so it isn’t a problem with some paths or files, but more likely some change in the way, the .smod-files are working…

I’m also using Windows 7, 64 Bit, so maybe this could be a reason, too…

1 Like

Exactly why I added it. I haven’t heard many other people complaining about it yet. lol


Maybe that’s because you can always extract the folder and (if the mod version is compatible with the game version), it will work either with the smod or with the extracted folder (I don’t usually leave .zip folders there…).

I think I tested some smods long ago and they didn’t work so from that time I always extract the mod folders… But now that this problem has got some attention it would be a good time to determine why smods work for some people/versions and others not, so when a mod manager is implemented in the future, problems like this won’t difficult its programming.