Problems with the stonehearth.smod file :-)

Greetings good people

Found this amazing game yesterday and I would like to try myself modding it a bit.
I have tried to uncompress it with win7 and rar, no problem.

But when I try to make it to stonehearth.smod and start the game I get a Assertion Failed …cpp:1980

No matter what I do I cant make the stonehearth.smod work, I even tried sitting naked with my underwear on my head singing sad baking recipies, that did not help either : -)

I hope some of you have the wisdom I need : -)

Are you just renaming the file, or are you zipping it up and then renaming it?

I zip it and then rename it

Do you get any error message if you leave the file un-zipped and start Stonehearth? Maybe it is not about zipping but one of your changes is not working out as expected.

How are you zipping it up? Inside the zip should be the stonehearth mod folder with everything else inside it.

I just tested it out on my computer and when I zipped up everything inside the stonehearth mod folder without the folder itself, I got the same crash error.

First, thanks for trying to help me out guys : -)

So lets dance

Lets make a test.

  1. I did just start the game to check if its still working, it is, so we are ready to go.
  2. Using 7-ZIp to extract stonehearth.smod, it extracted to mods\stonehearth\stonehearth
  3. Moved the original stonehearth.smod to my desktop.
  4. Time to see if the game can start at all, the folder stonehearth is open, not ziped back to .smod
  5. Crash : Assertion Failed …cpp:1980, hmmmmmm
  6. oki, gonna compress it with 7-zip and after rename it to .smod
  7. Compressing went good, the file is a bit smaller now.
  8. Trying to start game and crash :-/
  9. bummer, what to do now?
1 Like

Well, well ,well, I found out why

Seems it was the directory error, the game did not like it was in mods\stonehearth\stonehearth
Now the it looks like this :\mods\stonehearth and its not compressed and the game starts up : -)

Thanks for the dance guys : -D

1 Like

The dance is over already? :frowning:


We can actually use emotes in the thread titles? :frowning:

1 Like

Hey I don’t know if this post is still being looked at, but I found the solution/fix to the problem:

  • When renaming the .smod file to .zip and then unziping it, it creates a folder to put the folder into…
  • Stonehearth.smod - ‘should’ when extracted be turned into a folder called Stonehearth, however, it creates a folder called stonehearth and moves the existing folder called stonehearth into it…
    Folder Location: …\Stonehearth\mods\stonehearth\ stonehearth
    It should look like …\Stonehearth\mods\ stonehearth
    Once you extract the .smod move the folder outside of the folder it creates and that will fix it… or at least it did for me. Hope This Helps!