Broken undo and entryless building

Summary: so building this pillar all of a sudden i notice it turn in to 3 builds…

I cant reproduce but here’s what happened.
what started this. By accident i selected walls (plausible room) instead of single blocks.

then i used that as a single block and for some reason it allowed me to place it in a single block area. doubling the slabs in same spot i notice this and use undo to remove the wall. 10-15 undo’s back.

then continue to build the pillar and notice this…what the pic shows…regret not saving it at that point…
but i tried to first remove the building by first finish editing and remove. did nothing so tried console delete nothing happened… So i saved at that point.

Now i can log in and delete it with console. and i can link the 2 buildings again but undo remains broken.
the 1 block in the corner was where the wall was placed and it still has a building number as well

so a few different weird things going on there. so uploading a save!

Expected Results:

Actual Results:


Version Number and Mods in use:
a18 r663

System Information:

1 Like

Caught it in the act this time and uploaded a save before i used “Destroy” on the building but same bug.
(i did try using ingame tear down and tried to reload and it acts like that never happened)
i build the highlighted wall first. then mine some lines of dirt with instant mine.

connect the 2 walls and then i notice they are several walls all of a sudden.

its near the 2 knights statues.


So i found the bug 100% now :stuck_out_tongue:
its pretty simple to reproduce really!

Basically if i start building something of a wall it will turn in to its own entity.
Like shown above thats 4 buildings

i think it then bugs out when i start connecting these together and it breaks undo…should have tested that >.<

but was excited i found it :stuck_out_tongue:

1 Like

yea thats totally it.

after i you reproduce it also allows you to put blocks inside walls by dragging.
deleted 4 rows of blue blocks to show that blocks are stacked in the wall with the color change.

no broken undo tho :stuck_out_tongue:

1 Like

and finally broken undo :stuck_out_tongue: not totally sure how i did that one tho >.<

1 Like

Not sure if this is the same bug but just noticed this.

walls arent solid :stuck_out_tongue: