Black Screen only a little showing? :(

Hey guys,

So I just bought Stonehearth, was playing just fine, albeit a bit laggy on the lowest settings, and night fell and I was centered over the middle of my burgeoning village with the firepit being started up and suddenly my screen blacks out with only a tiny portion showing.

Here’s a screenshot of my game window. And here’s my PC specs. I’ve got an AMD Mobility Radeon HD 5470 display card as well. (Not sure why Intel HD Graphics is overtaking my display tab. ).

Both are in an imgur album. (click the image to get to the album)

I have no idea how to fix this, I’ve even tried forcing the game to 32-bit to see if that did anything, and I haven’t found any viable solutions anywhere online. I can only manage to save my game and exit it by shrinking the window down to a tiny tiny box on my monitor and hope-clicking on the save buttons.

Please help me find a solution! :frowning: I really want to play this game but if this persists it’s basically unplayable for me. :frowning:

Edit: I undeployed the firepit and I was able to make it through a couple of nights, though when I had the camera facing a house I’d put down, suddenly I got the black screen of death again when night fell (I suspect from the lamp I’d installed on the house having the same issue as the firepit). :’( I think maybe something with the light particles in the game keep causing this? I don’t know what to do to fix it, but…yeah. :frowning:

1 Like

Hello @Reverse2057. Welcome to the forum :smile:

First of all, I’ll tell you a workaround to avoid your screen for becoming that black:

When you see it’s almost night time, focus your camera away of the firepit or any source of light / particles. You can turn the camera once all the lights have been lit (you will notice that the game freezes for a couple seconds when the firepit is lit / lamps are turned on). Normally this helps to avoid the problem (I suffer from it too).

Sometimes, after trying to move the camera randomly during some time, the blackness goes away, but it’s really tricky.

Oh, you already found about it. Anyway, it’s worth the try.

And I’ll page @not_owen_wilson for more info. This is definitely annoying, since you can’t play during lots of minutes as you can’t see almost anything on the screen.

1 Like

Hey @Relyss

Thanks for getting back to me on this. I’ll give your tip a try and see if focusing the camera away helps out. I’ll report back here if it helps me. :slight_smile: And thanks for the welcome!

Maybe something can be implemented to toggle light particles off and on, for players that suffer from this? Just trying to think of ways to help fix this if there’s nothing else that can be done for future patches to figure out why the particles cause this phenomenon.

EDIT: Okay, so I tried the looking away trick and that seemed to work for the first evening I attempted it. I also switched the building view so all the walls were hidden, which I’m not sure if that helps any on making the light particle emitting source disappear, but I don’t see any light on the ground outside the house i’m currently pointing the camera at. So I’m wondering if switching everything to view inside the homes helps?

I’ll keep updating on any more results I find. :slight_smile:

EDIT #2: So I saved the game and closed it to add the debug feature, and in re-opening the game, I had saved it while it was night-time and consequently the camera was also aimed at a house. When I opened the game it was the black screen of death again because the housing view slice had gone back to default with the walls up.

So a warning to any suffering this phenomenon, make sure, if you save/close the game while at nighttime, make sure you’re aimed away from a house so that the game doesn’t reopen with you aiming at a house or light particle when you open it again. Otherwise you’ll get the black screen.

1 Like

Edit: hah, I found my report on a different topic… Merged.
I feel bad for not have commented before:

Having a flash when lighting the firepit, it’s a problem that I always had. Since the very first Alpha. But, in my case, it’s worse. Now, thanks to the light rendering improvements, the associated momentary lag only happens if I watch how they light the fire, and I really appreciate this. :relaxed:

But still, the game window gets black, and stays with a weird camera/ui for some seconds (sometimes I worry that it won’t come back to the normal state, but it always fixes itself in the end)…
I mean this, for example: :disappointed_relieved:

It’s like if the game controls got stuck momentarily, and a flash happens, and then the window gets black and stays like that for some more seconds. All this happens the moment the fire is lit (I can see the initial sparks normally). I think I can see the settlers moving during the post-flash seconds but as most of the screen is black I can’t do anything.

Is there any strange code for that event that’s causing the flash? Or it’s just the night falling that activates many triggers? :anguished:

No one else has complained about this, so I’m not sure… it could be my specs or something…

Windows Vista Home Premium SP2 (32-bit OS)
Intel® Core™2 Duo CPU P8400
2.26 GHz 2.27GHz
Mobile Intel 4 Series Express Chipset Family

1 Like

so I haven’t figured out yet what causes this yet, but at some point about 90% of my screen goes black aside from a small portion in the lower left corner. (Image Here)

sometimes this will happen within the 1st day, other times later. The farthest I have made it to about day 6 until this bug happened. if the game is saved after and then reloaded the screen is still like that.
I am running on:
Win 7 (64)
HP pavilion dv7
i5-2430M (2.40GHz 2.40GHz)
8gb ram
intel HD3000
resolution of 1600 x 900
but the issue still happens on other resolutions aswell.
I also screen caped the farming option typos “growning” instead of “growing” for Carrots, and Corn.
Hope this helps, this is my 1st time ever reporting a bug for something so im not sure if I gave enough info but there you go. love the game, cant wait for the future to finally see 1.0!
:slight_smile: thanks guys!

hey there @Forgotten_Legend, welcome to the discourse :smile:

i embedded the picture for you.

anyways, onto the problem at hand, are you perhaps playing in full screen? i know that this issue has happened before due to problems with fullscreen.

and if you are playing through steam, are you playing the A11 “stable” or A12 “unstable” build?

1 Like

I have not played in full screen (too slow on my computer and laggy)
It IS through steam, Alpha 11 :slight_smile:


hmm… perhaps try opting into betas, as i believe something like this bug was fixed in the A12 unstable, there are instructions on how to opt into betas at the bottom of this page,


oh thanks, ill take a look at that :slight_smile:

Carrots and corn, always so grumpy…

So the same issue is still happening on steam A12, I was playing windowed. also I noticed that trying to set up a trapping zone almost never works (using button or hotkey “t”) once I drag n release, nothing will happen until I do it about 20 ish times then it will pop up with a confirmation box. iv tried it on many maps, and in open space usually.
hope this helps =)

[quote=“Forgotten_Legend, post:7, topic:16937”]
So the same issue is still happening on steam A12, I was playing windowed.
[/quote]alrighty, could you provide your stonehearth.log file, it should be located in,

C:\Program Files (x86)\Steam\steamapps\common\Stonehearth

since your a new user you’ll have to upload it to a file sharing site such as dropbox or googledrive, rather then directly to the discourse, once you do that just provide the download link so we can take a look at it.

i’m also going to page @Albert for this.

in order for the trapping zone to be set it needs to be at least 10 x 10, fo reference the numbers on the side tell you how big it is.

@Forgotten_Legend - Welcome to the forum. Your Intel graphics drivers are about 4 years old which has known problems. Can you update them from this link?:


hmmm seems to be up to date :confused: (still having the issue.)
Here is a new log, I closed the game just after the bug happened this time, so the issue should be in the last minute or 2 of the log.
Log Link:!iw8HCSBR!8COzNjIvencw7wnzK439w2I-QQCfLOmY3kdnSzDnQcg

The log is reporting Intel driver version which is quite old. If the Intel site couldn’t update them, you might need to check with HP to see if they updated their customized drivers.

1 Like

2 posts were merged into an existing topic: [Con] R 2609 - Males with outfits losing their heads! (all affected, mostly footmen)

@Forgotten_Legend. The black screen can go away after a random amount of time, but not always. It is due to the lights and particles triggering at night. To avoid it (workaround), when you see that the change to night is almost there, just face the camera away of the firepit and other light sources until everything gets lit (some seconds depending on your own lag). This usually prevents the blackness to appear.

I’m going to merge this topic, since other people also reported it and it used to affect me too.

1 Like

I have a work around for this problem!Shrink the screen down to the little box showing.It’ll turn into a real small playable and barely view-able game.Then save the game and shut it off.Reload the game toggle full screen mode on load your save.I can get it to work everytime,however I may have to do it a few times.Save toggle fullscreen on if its off or off if full screen mode is on but make sure to shrink the screen to the little box to enable saving.The graphics driver is best supported atm.I don’t know if its a direct x11 issue or a open GL 2.0 issue.I can get the same effect on my desktop I think its caused by cpu and memory issues I use a 4500HD laptop and a new gtx on my desktop.I haven’t been on the new builds since the last 2 updates currently waiting for pathing to fix.For me the problem seems to occur from taking memory and cpu usage past 98%.