Befriending Multiple Animals Causes Game Crash

no_longer_applicable

#1

Title: Befriending Multiple Animals Causes Game Crash

Summary: After learning that the animal-befriending feature had been implemented, I immediately began a quest to subjugate all of the critters in the world to my will (well, all of them that I could reach anyway). However, after befriending a certain number (it seems to vary, but somewhere in the teens) the game will crash the next time I attempt to trap another animal using the “2” key.

Steps to reproduce:

  1. Promote a settler to trapper.
  2. Trap multiple animals and befriend them all, have at least 12 following you.
  3. Attempt to trap additional animals using the “2” key. At some point, this will cause the game to crash.

Expected Results: Trapper would keep befriending animals

Actual Results: Game crashed when attempting to trap additional animals.

Notes: I’ve experimented with this and found that it does directly relate to the trapper, as I can have a game running for far longer than it does when the trapper causes it to crash. I also believe that this relates to attempting to trap a certain number of animals–since the game does not crash until the exact moment I press the “2” key after reaching the limit, regardless of how long the interval is between the last animal successfully trapped and the subsequent trapping-attempt. Unsure as to whether this also applies to harvesting animals, also unsure as to what the exact limit is.

Attachments: here’s a video: Stonehearth Alpha 2 (r58): Befriend ALL the Animals! timestamp at 9:20 (I began fast-forwarding the footage there, though relevant information might be gleaned from beforehand).

System Information: Windows 7, 64-bit OS, i7 processor, 8G of RAM


#2

thanks @martyrsvale … given the feedback in this thread, i suppose we can call this one confirmed…

and the extra video footage may help @sdee and her minions track it down… :smile:


#3

Thanks for testing it out! Paging in @Albert


#4

i 2 can confirm but only had 3 rabbits and was about to get a 4th until it crashed


#5

There’s no hardcoded limit to how many pets you can have. I’ve had about 20 some before deciding to quit. With that said, each pet takes up AI resources, so the increased stress on the AI system may reveal bugs more frequently. I haven’t been able to reproduce a crash from too many pets, but I do see them slow down and stop following because the pathfinder doesn’t find a solution before the trapper goes out of sight range.

Try bringing the pets back to camp too. They have a few more behaviors when there are others around.

Also, regarding the targeting of the trap, did you try to ESC out of it? (You may need to hit ESC once for each time you hit 2. It will also bring up the in-game menu too as another bug/side effect…)


#6

I noticed the animals failing to follow after I’d gathered “too many”, though I hadn’t tried bringing them back to camp. With regard to the trap-targeting, I only hit 2 once in order to initiate the bug, and hit ESC at least twice in an attempt to disentangle myself from it (both times it brought up the menu, but neither allowed me to select another unit).


#7

Thanks for the clarification. It’s on our list to update the UI so that you can’t issue another command until the previous one is resolved or cancelled.


#8

Aha, an elegant solution. Thank you very much for the update!


#9

sooo… methinks tagging this one “acknowledged” is in order? :smiley:


#10

I haven’t seen that issue yet. What I’ve noticed is if the trapper is walking and you press the 2 key it crashes the game. Were you standing still or moving when this happened?


#11

Just tested, and I can’t seem to replicate your bug–whether standing still or moving, neither pressing the 2 key nor clicking to set a trap will cause the game to crash. However, after garnering about 15 animal followers (the number varies, and some don’t necessarily follow) the game will crash the next time I press the 2 key.

Side note: also realize you can “queue up” a set of actions, for example, pressing the 1 key repeatedly will seemingly result in a number of orders to move to a location equivalent to the number of times you press one. After doing this, you can click to move without pressing one, and each order will reduce the count by one until you’ve exhausted the orders you “queued up”. However, I think some of these issues might be solved when, as @Albert said:

It’s on our list to update the UI so that you can’t issue another command until the previous one is resolved or cancelled.

So that’s cool :slight_smile:


#12

So far I haven’t been able to reproduce this! :\


#13

Interesting… I might inquire of two things: how many animals did you successfully gather, and what are your system specifications? This is just a theory, but seems to make sense to me. I’m not the only one who’s experienced this bug, but others seem to have the game crash at a lower number of animals (see @blackArcher52 above). On the other hand some (like the developers) can’t seem to reproduce this at all, they only get the pathfinding errors. It’s possible that the crash occurs earlier on lower-end systems, later on middling ones, and does not occur on higher-end systems. I would assume that the devs have pretty beast computers; and I know that you have an i7 CPU, NVIDIA Geforce GT 635M, and are running a 32 bit OS on a 64 bit machine, which seems pretty decent, though I don’t know about the RAM. Likewise, I don’t know anything about the aforementioned’s machine, so my theory could be totally without merit.


#14

i think you might be right casue im no were close to an i7 i got a amd dual-core that can go up to only 1.33 GHz


#15

I’m consistently getting crashes whenever attempting to trap anything at all (soon as I hit ‘2’ or click the button) on both my computers. Not terribly surprised, if it’s memory-related, far as the laptop is concerned (Win 7 64 bit, 4 GB RAM, AMD E-450 APU), but though I don’t know the specs of my desktop offhand, while it’s starting to get on in years a little it definitely is better than the laptop and can usually handle games that make the laptop cry.

The crashes I’m getting, to be clear, are just “quiet” crashes, where the game decides from one moment to the next that no, it’s not ACTUALLY running anymore, bye bye. (As @martyrsvale mentions hitting ESC to try to get un-bugged and getting the menu, implying in that case the game crashed a bit more gracefully.)


#16

@quoting_mungo - I suspect that the game is crashing when trying to render the targeting reticle. Our code might not be compatible with that AMD APU yet. Did you configure your game to send crash data to us?


#17

@Albert - I believe I did; I’ve got the memory of a gnat, but I can’t see why I wouldn’t have. Curiously, it seems to be working fine on my desktop (which wasn’t as awesome as I thought; same stats aside from a Radeon 5700 card) now (yay!). I’m just happy it’s working for me on one machine, at least, now.


#18

thanks for the follow-up! if you no longer see the “opt in” button on the start screen, i believe you would have selected it… unless of course it only runs once, on initial launch?

@sdee, does the button remain until and unless the user selects it, or does it only pop up on that first launch, and then fade away?


#19

The button appears when the game first runs. If you opt or out then, it never asks you again, unless you wipe your user_settings.json file.