Assertion failed! - in function 'report_traceback' - in function 'can_start_blueprint'

Summary: Can’t place slabs any more in the building editor all of a sudden. I was laying out a foundation to build upon with Rayya’s Children. Worked Once before.

Steps to reproduce: Unknown.

Expected Results: Working like slabs work.

Actual Results: Error message. Can’t edit slabs at all.

Notes: Engine Error reads as follows:

release-519 (x64)
stonehearth/lib/build_util.lua:332: assertion failed!
stack traceback:
	radiant/modules/common.lua:214: in function 'report_traceback'
	radiant/modules/common.lua:225: in function <radiant/modules/common.lua:219>
	[C]: in function 'assert'
	stonehearth/lib/build_util.lua:332: in function 'can_start_blueprint' in function '_start_project' in function '_updates_state' in function 'obj'
	radiant/modules/events.lua:76: in function 'instance'
	radiant/modules/events.lua:209: in function <radiant/modules/events.lua:203>
	[C]: in function 'xpcall'
	radiant/modules/common.lua:234: in function 'xpcall'
	radiant/modules/events.lua:203: in function 'trigger'
	radiant/modules/events.lua:272: in function '_trigger_gameloop'
	radiant/modules/events.lua:323: in function '_update'
	radiant/server.lua:62: in function <radiant/server.lua:58>

Attachments: Save file. Error pops up right after loading.

Version Number and Mods in use: Official Alpha 14 release.

System Information: Core i5, 8 GB RAM GTX 970, Win 7 64 Bit

Btw: If I opted into sending anonymous feedback, do you receive all error messages I get automatically?

That is a question for @Albert. I know that crashes get reported, but I am not sure about Engine Errors. That being said, even if engine errors are reported, reports here are still appreciated, as sometimes the error log is useless without context. Sure, an error occurred, but what caused the error!

Now that you mention it, it sounds pretty obvious. :wink: Thanks for clearing that up.

1 Like

As far as I know, the reporter is just for the crashes. It would be a chaos if they received all the engine errors :sweat_smile:

1 Like

Assuming they had an automated system for dealing with duplicate errors, it might not be that bad…


Hi there,
I have this exact same error as of last night. I was editing with slabs, so that could have done it, but I also may have purposefully tried to break something.

I put a bunch of slabs in the ground and then discovered that I couldn’t just automatically have walls wrap around the floor. At first I ignored it and went to manually build up walls, but that got annoying, so I tore them back down, and removed the slabs in the ground. Unfortunately, then I discovered that I couldn’t just re-lay a proper foundation into the hole in my ground, it still wouldn’t let me have walls.

So I placed a bunch of slabs in the hole, and then discovered I could lay foundation right over where I had put the slabs. Which I then did. I think as soon as I had slabs and foundation in the same hole, it gave me the engine error.

I also had a bunch of other weird things happen afterwards, like I tried to remove everything out of the hole and it would remove the foundation but not the slabs, or it would remove both but then in the (seemingly) empty space there were certain parts that could no longer be built in/on no matter what.

1 Like

Hey there @Kat, welcome to the Discourse! Thanks for the report!

1 Like