Another Building Bug

I didn’t categorize this because I tried to do something that wasn’t part of the building feature yet. But I’m posting it here because it should be looked at.

What I tried to do was build a house that had different rooms using a method. Anyways, here it is.

i have categorized it as active bug, as it still is a bug, even if what you were trying to do isnt implemented yet.


Well, thanks for doing that. Its been a while since I’ve tried to play stonehearth. I’m mostly waiting on Alpha 11.

I want to see what was added and what was fixed.

For me, some changes include:

-[Bug] Headless villager fix

-Updated building feature: Not necessarily compartmentalization but just being able to build buildings without an obstructive view of the building.

  • Slice view also slicing view for buildings

  • Buildings don’t require roofs: elaboration is needed here because the devs did fix this. But I decided to break it again. What I did was try to build a 2-story house with a chimney. The chimney is modeled like a chimney. Guess what? The house didn’t build. Not one brick. I suspect it may have to do with roofing like previously. I could be wrong.
    But what could be nice, in the future, is to have pre-made modules to add onto buildings, which can include a belltower or a chimney.

  • I don’t know. I’ll let the devs do their thing.