Alpha 17 dev. 3013 - Shared Sleeping Quarters - building doesn't complete

I’ve generated several new games to see if this is a reliable issue in Alpha 17 dev. 3013. While I can build the template for the dining hall perfectly, the shared sleeping quarters does not complete properly. The building appears complete with windows, doors, furniture, roof, but scaffolding remains and the hearthlings are actually entering/leaving the building via this scaffolding and climbing through the roof. I tried to do a custom building with beds and have the same issue.

Steps to reproduce:

  1. New save
  2. Make sure you have a carpenter and wood
  3. Build Shared Sleeping Quarters building template

Prior to dev 3008 this was not an issue and all buildings were completed as expected, dev 3010 and 3013 seem to have this building issue

I don’t have any mods installed and given the buildings worked in previous versions and I made sure to have new saves after the dev releases there shouldn’t be any version conflicts.

A post was merged into an existing topic: Hearthlings Don’t Take Down Scaffolding