All Landmarks are Red

Whichever map I launch the game most landmarks (apart from stone statues) have various blocks colored red, regardless of season, clan or save file. For the record, I’m running the Steam version of the game, which is automatically updated. All mods are from its Workshop.

I’m not quite sure when this started happening or how to reproduce it, but I think it was sometime after I re-embarked with the Firefly clan. Removing the Firefly clan mod did not fix it.
Apart from that, I have various building template mods installed as well as ACE, Fisher Job + Archipelago Biome, Muramasa Clan, LostEms, Extra Map Options, Better Storage and Age of Giant -Piles.

I’m not familiar with modding apart from downloading + installing them on most games so if anyone has a solution, um, I’d ask for as detailed and simple guide as possible.

1 Like

Red is the color that is given to a landmark block when it has no “assigned” color for that type of block. The assigned colors to each type of block are defined on the biome generation file, so this problem is 99% likely related to the biome being used and not to any other factors like factions, reembarking and such.

I can’t exactly tell from the first image but the second and third one seems to be the japanese biome from Clan Muramasa?
If that’s the case, it’s possible that they haven’t set up all rock colors in their biome generation file. It’s really important to set all the rock colors - even if your biome doesn’t use it - because sometimes landmarks can use them. That’s my first guess - but I suppose there’s a 1% chance it could be something else :merry:

Either way, I’ll ping @Findersword and he’ll be able to check if that’s the case :slight_smile:
Finder, make sure that all rock colors - from 1 to 8 - are defined for all seasons :slight_smile:

– Edit:
I just checked and it seems to have all colors properly defined, I’m double checking if the mixin made for ACE could be somehow changing that though (or affecting it)

– Edit 2:
I’m talking with Finder and apparently he changed the rock colors on a recent update - which would explain it breaking for existing saves… But it should work for new saves. Could you please confirm that a new game created right now has the red blocks? @Firas

1 Like

So far, I haven’t been able to see that bug, in my testing between a save of the original rock colors, and the updated version. Perhaps try unsubscribing and resubscribing to the mods in use, it could refresh their data?
Which other kingdoms and biomes did you also see it for?

1 Like

I’ll try re-subbing all my mods, but so far, it isn’t limited to just clan Muramasa. I did another check just now and even Ascendancy in their preferred biome gets this problem, as well as in Highlands.

1 Like

Ok, now this issue got officially weird :jubilant:

I’m trying to figure it out as well

2 Likes

Please show a list of all the Mods active on here, if you have some more than the ones mentioned above, if you could!

1 Like

@DaniAngione
I’ve tried Ascendancy + every map as well as Muramasa + every map, including Yamato hills and Archipelago. I’m still working on Rayya’s children and the Northern alliance.
Difficulty doesn’t seem to affect it either, since I’ve been picking Gentle and Peaceful at random with same results.

@Findersword
I’ve unsubbed and re-subbed all of my mods, but it hasn’t helped. Like i just wrote to DaniAngione, I’ve tried out a number of kingdoms and biome combinations.
As far as the mod list goes, it’s pretty long if I include the templates. From the ones that affect gameplay, that I hadn’t mentioned are: Seeds for All! [Fixed], Home sweet home and Settlement Decor.

Building templates though are:
Northern Alliance Temple, [Fiva] Carpentry and Mason with two workspaces (Ascendancy), Five Man Quarters, Riallwood - Basic Template Pack, Aye - cottage for four, Market Place, TMD - Tier I, II & III Buildings, Geomancer’s Tower, Silverthorn Tier 1 Buildings, Silverthorn Carpenter House, Skuldos - Basic Template Pack, Vasedro - Basic Template Pack, Vasedro - High Template Pack, City “Sapphire Down”, Rayya’s Compound T1 Buildings, Norman Homes, Rustic Russian Residence Pack, Egyptian Cult Temple for the Monkey, Geomancy Block Farm, (Early Game) HEARTH TOWN CENTRE [Vanilla], Chosen of the Desert Tier 1 & 2, giant monkey statue, Desert Temple Tier 1, Desert Mansion, Skuldos - High Template Pack, [ACE] TMD - Tier 2 Buildings, Persian Architecture Pack, DFC Templates, Vaffel’s Template Pack 1, Settlement Decor, Town Center “Little Palace”, Tavern “King’s Krown”, The Hearth, Painted Desert Builds, The Great Ziggurat of Ur (Landmark), It’s Beachy! Back to the Beach in the Archipelago!!, 2 story farm cottage, Defenders of the North Complete, Village Builds for Clan Muramasa, Temple Shrine for Clan Muramasa, Muramasa Temple, Clan Muramasa, Set 1 & 2 The Orient Awaits

Oh wow, I think I found the mod that was breaking my landmarks!
The Great Ziggurat of Ur (Landmark) adds a landmark. I don’t remember when I added it, but after unsubscribing from it, my new games had landmarks that weren’t red.

I’ll try out a few more kingdom/map combos to verify it was indeed the culprit.

3 Likes

It’s the culprit, yes. :jubilant:
Good job tracking it down!

Indeed the problem is somewhat what I said in the first message but done through the weirdest way… Instead of through the biome, how you usually define colors, what happened is that the mod actually defines 3 colors in its landmark_blocks data that are already used in the base game data as rock colors… However the mod only add these 3 colors to two biomes, a modded biome and the Desert. So all other biomes will have these 3 colors broken since their names/ids got redefined.

The colors are:

   "#918D86": {
      "terrain_tag": "natural_gray"
   },
   "#82807B": {
      "terrain_tag": "friar_gray"
   },
   "#76726B": {
      "terrain_tag": "tapa"
   }

I’ll now tag @AndrealVox the author of the mod:
Andreal :jubilant: looks like this mod of yours breaks the base game a little. You need to define new colors for the above landmark blocks as these are already used by the base game.

That’s it!

4 Likes

“They constructed the Ziggurat to appease their deity, but the toll on the workers left many blood stained stones over the land…
.”

4 Likes

this should be flavortext somewhere :stuck_out_tongue:
" The histories of the Great Ziggurat of Ur, annoted, second edition"