[Ack] Settlers carry invisible objects

Title: Settlers carry invisible objects

Summary: Sometimes settlers carry invisible objects. When they arrive at the stockpile, the object becomes visible (be it a basket, a log, etc).

Steps to reproduce:
Sadly, it’s a random thing. If I find something to relate to, I’ll update the post.

Expected Results: The object should be visible while carrying it.

Actual Results: The object is invisible while carrying it.

Notes: I’m talking about carrying objects without any stockpile attached to the settler, nor anything else they could be carrying or affecting them.

Attachments: Geez, I didn’t make a screen. Well, I’ll borrow this one meanwhile.

Versions and Mods: Alpha 3 R80

System Information:
Windows Vista Home Premium SP2 (32-bit OS)
Intel® Core™2 Duo CPU P8400
2.26 GHz 2.27GHz
Mobile Intel 4 Series Express Chipset Family


Okay so I tried the stockpile issue and I stumbled across the invisibility issue at the same time.

I’m not sure if this is the correct steps but anyway, I removed stockpiles, @sdee these stockpiles attached to the logs rather than the settlers as shown here:

When my settlers went to pick the logs that are the start of the removed stockpile (the ones in the top left corner) the stockpile was picked up with them:

Now I’m not sure if it was this that caused the invisible items, but the next items that were picked up by those settlers were then invisible:

Also this settler picked up an invisible removed stockpile:

If it was, then the cause of my invisible baskets would be the invisible plots.

Yer I’ve altered the floating stockpile post as I believe the stockpiles attach to the items, I also had the invisibility thing happen to me, the same two workers went to pick up some harvested stone and on both occasions they travelled with an invisible object, this was done after I removed stockpiles so not sure if that impacted it, the other settlers moved the stone fine:

Ignore the error, that’s because the UI was still there for a removed stockpile and I tried clicking the button for it:


I know this bug happens (from experience) when a model isn’t referenced correctly in the entities .json file. Although if that happens, it never appears.

1 Like

You guys are so awesome. Paging @not_owen_wilson, again. He is tearing up the bugs this morning!


I kept an eye on a little girl who carried an invisible object, and I saw that all the resources she picked up became invisible in her hands. They must have ESP or something :worried:



and again an little bug :wink:

Steps to reproduce unknown but the cargo will be visible in the stockpile and it´s only for this one person xD

1 Like

I’ve noticed that this bug appears to have reared up in the x64 version of the game.

The Crafters would carry an object to be made but once the object is created it will be invisible whilst carried back to the drop-off. Only reappearing when in the stockpile or left on the ground.

one thing I did notice was that once the object was made it appears to fall through the workbench/ground. Could this be why its invisible ?

Carry thread:

Carrying a Mean Bed:


Yes, it could be. I remember I once saw that same issue, a crafted item falling through the floor. It’s difficult to repro…

I noticed this as well during my play in R393. Visible in the attached video at 41:59 and a few more times immediately after.

1 Like