[A9 256] Bed wont be placed


maybe bug or my hearthlings are just lazy but they don’t want to place bed in shelter for 2 :frowning: I have beds in stock and even when I TELL them to do it they dont. :confused:

Encountered it too, they placed 2 beds from 4 (I have built Shared sleeping quarters). Also they have “placed” bed and that bed was in stockpile.

Once one of the cottage for two I was building didn’t finish. The villagers were unable to install the wall lantern I had in stock (maybe they didn’t like it?). As soon as I tried to place it myself one of the villagers rushed to the stockpile and finished the building.

I believe this is the first time this problem has been introduced into these forums.

So basically I placed down 3 beds and then the workers don’t place them.
They simply slack off in the campfire at night and go to sleep, then eat, and repeat the cycle.
They don’t have anymore tasks, simply just putting 3 beds down…

To fix this, try to save your game, exit, and then re-load the save. This sometimes fixes it for me.

Maybe the hearthlings can’t access the inside of the building. Or don’t want to do it. You also have stone bricks laying there, and if you have an appropiate stockpile, they should carry them to it (besides placing the beds). So I think the problem might be related to the building itself…

Anyway, try the workaround that @TheDerpySupport suggests to see if it helps.

I tried to get the stones out, but now they don’t wanna loot them…

Click on the Stones;
Push your ` Key on your keyboard;
Type " Destroy ";
Hit Enter;
Succeed; :smiley:

But that doesn’t get rid of the furniture bug. Let me search the duplicate…

No, that wont get rid of the furniture bug but it’d get rid of the unmovable stones.

Well, I removed the stones and undeployed the bed, but I still cannot place a bed in that specific place.

Can you erase the ghost beds with the erase/clear tool?

No, they haven’t added an option to get rid of anything ghost yet.

You don’t lose anything for trying to delete them anyway. They’re less ghostly that you think :wink:

If they can be moved when in ghostly state, why couldn’t we delete them too? (In the worst case with the console)…

I did try, but it didn’t even select the ghost bed.

1 Like