[A18/A19] The buildings my hearthlings will not build (round 3!)

Alpha 19,
687 (x64)
no mods

not a custom building.
The clay dormitory that comes with Rayya’s outpost templates will not complete. Everything finishes and the scaffolding removed, but the final window (front rightmost) never gets placed. tried building multiple times.

Hello, it’s been a long time since I’ve played Stonehearth, so I decided to see how it has developed. A lot of progress has been made, it has become quite a complete and engaging experience.

I came across the problem, however, that when building the Rayya’s Children version of the Forge prefab, it never completely finishes. It gets to a certain stage of construction, where all of the blocks have been placed and all of the windows installed, but not the door, forge, anvil, or lamps, and then the hearthlings pull down a bit of the scaffolding and just stop. I tried putting many ladders around the building, which sometimes works when the hearthlings get stuck building things on the edge of cliffs or some such. Then I thought that maybe the area was too crowded for them to access some parts, so I placed the template out in the open a couple of times. However, whatever I tried, construction always stopped at the same place.

I don’t know if this prefab has been successfully constructed before, but for me, in this build, it seems that the prefab itself is the source of the problem.

I had a similar experience with some custom buildings. They got constructed completely, except for one final object. In most cases, this was a door. The missing object was in my inventory, though. Sometimes it helped to order a crafter to manufacture one more entity of the missing object, which was then placed and the building finished correctly.

Welcome to the forum, @Bickler and @Alfalfa :slight_smile:

In this case (the forge), the hearthlings should have finished removing the scaffolding, and they didn’t, it is a bug.
I have no problem with the Clay dormitories, though. Do you have a savefile where the problem is happening, @Bickler ?

1 Like

Unfortunately, Several game days have passed (15 or so) and I’ve overwritten the save file. I tried the dormitories again and the problem can no longer be recreated. >.< A fluke.

@Alfalfa As for the forges,They always get to the same point where they’re deconstructing the scaffolding. They get stuck when they try to remove these pieces, which no longer have a path to them, as they have already removed the ladders to them. If you delete or create ladders to these pieces of scaffolding, they will complete the job.

3 Likes

Ah, thank you. I’m almost certain I would have never noticed that. I got around the problem using instabuild this time, but I will remember that for the future.

Summary:

Some buildings that are built using templates sometimes don’t finish construction. Most examples are one window frame and ladder of the entire building remains shaded as if it were in construction queue. There is no option to remove ladder or frame. Other instances include chairs and tables. However, while chairs and tables don’t appear dispatched, they are used by hearthlings.

Steps to reproduce:

  1. Construct buildings using building templates. Problematic buildings include kitchen and residential dormitories.
  2. All but a few items are built and remain shaded to appear as if they are in construction queue.

Expected Results:

Completed building.

Actual Results:

Partially constructed building with one or more items not dispatched.

Notes:

Attachments:

Version Number and Mods in use:

Alpha 19, current version as of 11/6. No mods.

System Information:

Intel® Core™ i5-4570T CPU @2.90GHz 2.90 GHZ
12.0GB (11.9 GB usable)
64-bit Operating System, x64-based processor
Touch Support with 10 Touch Points
Windows 10

Hey there @dakolson, welcome to the Discourse :smiley:! Can you share the problematic templates?

In order to upload a building template:

  1. Save your build as a template in game.
  2. Open your game directory.
    Default location for a Steam install is:
    C:\Program Files (x86)\Steam\steamapps\common\Stonehearth
    Default location for a Humble install is:
    C:\Program Files (x86)\Stonehearth\
  3. Navigate to the building templates stored in \saved_objects\stonehearth\building_templates
  4. Locate the .json file for your template. For example, if you wanted to upload the “Clay Dining Room” template, find clay dining room.json.
  5. If you created this template in a recent version, you will also have a .png, for bug fixing purposes this is not important and does not need to be included in the .zip.
  6. Compress the .json file to a .zip file.
  7. Right-click the file you wish to zip.
  8. Left click Send to.
  9. Left click Compressed (zipped) folder
  10. Hit Enter on your keyboard.
  11. Upload the file to this thread in the Discourse by clicking the upload button in the editor and navigating to the file, or drag the file into the editor with your mouse.

@jomaxro I think he means the default RC templates.

(I’m going to merge this with the main thread)

What do you mean by this, @dakolson ? :

Also, welcome to the forum ! :slight_smile:

1 Like

That’s what I was assuming, and I was waiting for a response to merge…

1 Like

Hi @jomaxro I am referring to some of the preloaded build templates. Some that I am having problems with are: clay dining room, clay dormitory, and clay house for two. In almost all templates, the one item that isn’t built is the top left window frame. In the clay house for two, sometimes the tables and chairs aren’t built, but are used by hearthlings as if they have been. Do you still need the templates uploaded?

If they are the default ones, there’s no need.

They are being used in ghost form? Could you upload the savefile that has that happening, please?

1 Like

Gyazo - ac652f002e339dd6b24d962d8390d03f.png here is a link to the picture of the carpenter house the hearthlings just stop building it pausing and resuming don’t work the carpenter doesn’t do his work

Hey there @Karthick, are you talking about the carpenter house template that is part of the game by default? If so, I just tested it and it builds, so there might be something else going on. Can you upload the save where this is occurring so we can take a look?

To upload a save, locate the folder in
C:\Program Files (x86)\Steam\steamapps\common\Stonehearth\saved_games (assuming a default Steam install), zip the individual save’s folder (not the entire saved_games folder), and upload it. If the *.zip is less than 10 MB, feel free to upload it directly to the Discourse. If larger, please upload it to a cloud storage site like Dropbox, Google Drive, File Dropper, etc. and post the sharing link here.

hey @jomaxro im sorry but i wasn’t in a very good mood yesterday so when i happened i just took a quick picture of it waited for like 4 days in game and then just exited without saving as i had just started it sorry about that :disappointed_relieved:

i can discribe what i did up to that point if that helps at all? @jomaxro

No need to apologize! It’s your job to have fun and enjoy the game, not plan to submit perfect bug reports every time!

As I mentioned, I tried building the carpenter house in a test world, and just finished building it in two existing saves without issue. My guess is something else was going on in your specific save. For now I am going to mark this as #not_reproducible - if you do encounter this again, please reply to this topic and we’ll move this back to #support:bug-reports.

Having same problem with Carpenter house. Built Shared Sleeping Quarters fine tho.

ed252dee-4d06-11e5-ab21-00ff0573e3

This topic has been archived - no changes of any kind (including edits) are allowed.

If you find templates that do not complete, do not destroy, require manual ladder placement, or have scaffolding that isn’t removed, please post them in the new topic: