[A10 R293 x64] [BUG] Walking on treetops

If a tree is next to the terrain, you can walk on top of it as if it was regular ground. I assume this must be due to the way hearthlings determine walking paths but it’s probably not intended :stuck_out_tongue:

I actually killed a goblin on a treetop so there was essentially a 5-man fight in a tree.


@MicrobeMan You raised a village of wood elf. Must be the only explanation :laughing:


That would be the single greatest thing I’d ever done in this game!


Is this really a bug? Do you think that they should they fall to the ground instead? :confused:
What if half of them remain on top of the cliff and the others fall? That wouldn’t be good for the battle…

I suppose that they are on top of the collision box of the tree.

It’s not a game breaking bug but I don’t think it would be intended for the tops of trees to be treated like level ground. Ideally they’d simply not walk out on top of the tree. Maybe some kind of “tree” notation in the code that would make hearthlings not recognize it as walkable surface.

I suppose the easiest way to keep it from happening would be to adjust tree height so they can’t be on the same plane as the ground, although I don’t know how easily that is actually accomplished.

I also had the same issue, except there is a goblin who is on top of his hut. My soldier will get into an area where he can detect the goblin, but then he will walk backwards. This will get me constant battle start and end music, which is really annoying. Also, when I try to kill the goblin, the soldier will just stand there, not really noticing him.

1 Like

@Void_Justice I had that too, have you tried making a party and get them to attack the hut. It worked for me?

I tired that, but they just… stood there.