[2867 bugs] The Miraculous and Bugridden Village of Zansink (including save file)

I’ve spent a good amount of time playing this town, and encountered a couple of bugs and things that bothered me, and so here below I’ll list them.

Here’s the download link of the saved game (was too big to upload here):

(The name of the town is Zansink)

What you might find within this saved game:

Super simple house not being built
The building as seen below is extremely simple, but my Hearthlings left it like that. I tried to pause the building and restart it, but then they just added the windows and door and said “It’s done!”. Well done, Hearthlings. Well done.

Weaver stopped producing things
I’d set a couple of things for the weaver to maintain in the inventory, including those large flags. As seen in the screenshot below, there are not enough materials for him to continue the production of flags, but instead of returning to produce Spools of Thread, which is the first in the queue, he instead insists that he wants to craft flags, despite the lack of materials.

(Might worth noting that the carpenter was also actively using the cloth to produce comfy beds, it could be related to the issue.)

Footmen stopped patrolling

No idea why; they’re just chilling at the last place they were dispatched to or fought a battle.

Lantern, lantern… why are you still not placed?

There are a couple of Fine Garden Lanterns in the inventory, and I tried to place them as seen in the screenshot, but they just won’t put them there. I had previously placed regular Garden Lanterns upon a similar wall with the same height (they are actually seen on the screenshot), and those were placed just fine.

Similar things happened with a couple of other objects, but unlike with these lanterns, those were magically fixed when I reloaded the game.

Many invisible things!
As shown in the screenshot below, the stockpile labeled as “Kevin the Stockpile” contains 395/400 items, but there are far more empty spots.

Two crypts?
Is this supposed to happen?

Lack of loot button on goblin wood
This might have been reported before, but I’ll put it in here anyway. So the goblin’s wood stockpile and wood carried, then dropped by goblins don’t have a loot button, so each time they pile up within my village I have to use the loot tool from the combat menu.

Farmers stopped planting things?
After playing for a long time, my farmers suddenly stopped planting new plants, but after reloading the game they suddenly started working again! Unfortunately I don’t know how to reproduce this, but I thought it might worth noting that this actually happened.

Edit: This issue seemed to reoccur every now-and-then as I played further into the game, each time I had to reload the game so the farmers would continue doing their jobs.

Also, it might worth noting that while I was playing this particular town, roughly one bazzilion errors popped up throughout the game, each with no apparent reason. I just ignored them and played on, but I just wanted to mention this, maybe it helps somehow.

And finally some more minor things and suggestions. Some of these might be things there were talked about in the past.

There should be an option to move or cancel the placement of an object
Many times I make a mistake and place the object to the wrong place; this is especially annoying when placing fences, because then I’ll have to wait until my guy/gal places the object before I can move it to where I originally intended to put it.

Removing roads/foundation should restore dirt/grass blocks
Ooops, I placed my road to the wrong spot, and realized it too late (or my Hearthlings constructed it with the speed of light before I could change my mind)… Now I have this ugly hole in my grass and no replacement grass. Aww.

Sometimes the game warns me about some thief approaching…
But then I click to see who it is, then I see a stray wolf. Wat?

Hearthlings should actively search for cooked food
“There are so many delicious pie over there in that chest, but hey… this raw turnip is a little bit closer, so let’s eat turnip instead!”
– Hearhling

This is all I could think of for now. Hope I was able to help a bit with this.

Some of those bugs have threads but yeah.

I also agree with some of the suggestion things (probably should be in suggestions forum but I don’t know how crazy people go about such things since I just started posting here myself). In particular I agree with

  • the removing road thing - experienced the same and ended up having to put the road back to not have ripped up earth

  • I would think hearthlings would prefer prepared food myself but the whole food thing is nebulous to me and I’d like more info. You see individual crops when farming, no clue how many make a bundle, is cooked food more potent or morale boosting than raw?

  • I have the same issue with moving/placing sometimes and I’m reasonably precise. Sometimes the game will autosave and throw off my aim or I just screw up though, and also have to wait for placement then redo since you can’t seem to alter the plan in progress

@CrazyCandy, wow, what a detailed list! Thanks for taking the time to write this up. Based on the reported bugs, I am going to ping @not_owen_wilson, @sdee, @Albert, @yshan and @linda to see this (well, I just paged almost all the devs…but there are a lot of distinct bugs here :blush:).

1 Like