[1658] On Load, assert in store.cpp

Continuing the discussion from Alpha 5, Build 1658 - Max_Level error:

Originally posted by @SnowmanJazz

…I’ve had this same town for a while and just recently started throwing “assertion errors” upon loading. I think that save was slowly becoming corrupt. I will have to start a new town and re-confirm.

error while loading save:


i’ve reached a point where I can’t go any further I get this every time. delete my saves to where I can start game and next save I have this error. also ctrl c just makes a ding noise and it won’t copy my user id so you get windows key print screen instead


@sdee I keep forgetting to mention it but I still have the zip file of my save if it helps any. I actually thought I deleted it. Would it be worth while to try and upload it?

1 Like

Sure! Can’t hurt, anyway. :slight_smile:

Well, I loaded it here: TinyUpload.com - best file hosting solution, with no limits, totaly free. Let me know if there are any troubles with getting to it.

Thanks again for everything, @sdee! You guys are awesome! :thumbsup:


First off, thank you for an AWESOME game! Been following you guys for a while now, and I hope y’all keep up the good work! :smile:

I’m having this same issue. It seems to always happen to the latest save, so if I delete that one and load up
another directly before it, the game will load fine. If I create multiple saves afterwards, close the game, then come back later and continue, I’ll get the same error.

My user id doesn’t seem to want to copy either :worried:

Edit: I’m actually using Build [1665]

1 Like

This have happend me a lot of times during all the Save and loadable Alphas. When i try to load a game, it crashes after just loaded about 30% loading.
Before i got an error that just said: ID

but now i got an error that said:
Assertion Faild: id(…source\dm\store.cpp:38)

and all the saves are from the current build.
i’m not loading games from old builds.

If you have other saved games! You have to delete them! I was getting crashes too and deleted all, but 1 game and it loaded up fine!

1 Like

Could also simply be that the save you’re trying to load is corrupted.

1 Like

But i don’t have any other saves?
not even in the steamapps/common/stoneharth/saves. there is only one save :confused:

yeah, the save could be corrupted, but almost all my saves that I ever had has then been Corrupted?

It is sadly a fairly regular problem ATM :frowning: .

Could try removing the save game folder from Stonehearth/saves and making/saving a new game. See if that loads fine etc, which will at least help determine whether it’s the game or your saved game.

1 Like

I experience this issue sometimes when it loads as well but it just crashes and no error message is even shown. Usually it happens when I’ve receieved some red error texts in game for whatever reason at some point. Even if things are better in the game and running smoothly it will still be an occurence.

hey there @edron5 … your post has been merged here, as additional confirmation of this particular bug…

thanks! :+1:

I start up the game fine and when i go to continue my current game the issue comes up after it loads about a fith of the way.

assertion failed: id(…\source\dm\store.cpp:38)

thsi is the error that is coming up. i also get a runtime failure message after. I tried some of the suggestions from a simalar post but none worked. If you need any other information about my system just let me know.

I restarted my stonehearth because I kept getting a error message and when I went to load my save it wouldn’t load it stayed at a little past a fourth of the way and it didn’t go any further.

@burton344, @caster12, have you tried deleting all the save files from the saved_games folder, (not from the esc menu within the game) and trying to make new saves after that?

Where would I go to get to that file?

If you play with Steam, you have to go to where Steam is installed, and navigate to the Stonehearth folder. For example:


There, you will see a folder named saved_games. You have to delete all the files inside that folder.