[1658] Assert on Create Save Game


#1

Simple enough: I was had a couple of saves of the world in the screenshot, decided to delete them both and make a new save. Deletion worked fine, but couldn’t make a new save. Clearing out the saved games folder didn’t help either. Could not reproduce on a fresh world however.

In the mean time, enjoy the only surviving record of South Ayesong. Two warehouses and a trapper’s home beyond the main structure. The main structure consisted of two towers, a gatehouse, and a couple of L-shaped corner buildings that were being worked on when everything broke. The whole thing was on a two-high raised floor (that had the pathfinding algorithms screaming for mercy whilst under construction, but I digress :wink: ).


[Dup] Game stopped saving
#2

Creativity is going to flow like a river once we reach some more stable builds. Right now it’s really tough to commit to much because I never know how long it will last. :smile:

Looked promising, @Teleros!


#3

Yep, same thing here.

I am unable to recall my saved games. The good settlement of East Rose is nothing more than a happy memory.

Curse you Assertion Failure!!!


#4

Just realized it stopped saving. I was about to get off when I went to save but realized it had not saved in a while. Anything I can do? I really don’t want to delete all my files in the saved folder like other posts have suggested. If I have to I will but I really like the worlds I have >.< sigh

version 1658


#5

Sounds like you’ve got a similar problem to me:


#6

Have you modified the game in anyay? Same question for you @teleros?

I found that after installing @Froggy’s mod a couple of versions ago I was unable to even start a new game until I removed the mod. Just a random thought, likely to be unrelated but hey, let’s exclude all other possibilities.


#7

Nope, always been the vanilla game for me.


#8

Same for me. Especially while the game is in Alpha. Maybe one day down the road but definitely not while it is still in testing.
@Teleros did you find a way to fix it without deleting your files? I currently just have my game paused and am hoping for the best lol


#9

Nothing I tried was any use sadly :frowning: .


#10

:frowning: well that sucks…


#11

Hmm, this looks like a different problem than the one where a corrupted save can cause the save UI to break, thus preventing you from being able to save/load more games. That means that the “delete the bad save” trick probably isn’t going to work. If you guys can get us a regular repro situation, that would be awesome. In the meantime, we’ll keep an eye out for it too.


#12

so I saved my game, but now it won’t open anymore… When I want to continue the game, a window pops up with: Stonehearth Assertion Failed: id

So i can’t play my… best game so far… anymore. I read that I have to delete my save now… In that case I’ll just let you guys know this is still an issue :wink:

The game itself is amazing even though it is still in alpha


#13

Is the game save from an older update perhaps? Maybe the hotfix yesterday affected it?


#14

@Geoffers747 No the game save is from the same day i started that particular map. I tried to open is on the same day too, after closing the game to fix a goblin bug.