Zooming problems

my zoom is broken. It limits me to a distance that doesnt allow me to correctly interact the game and see things closely. Mouse wheel down should zoom my view out but sometimes zooms it in instead. Mouse wheel up should zoom my view in but it doesnt sometimes. It feels as though my zoom has some sort of ceiling that the camera hits preventing me from getting a closer view of the world and if do have a close view of the world it prevents me from zooming out.

Steps to reproduce:
I dont actually know what caused this but I was messing around with a small body of water in a mountain area of my map. So I think the game recognises it as the new sea level and has prevent me from zooming past that body of waters height.

Expected Results:
Zoom function working
Actual Results:
Zoom being limited and mouse wheel up and down functions sometimes being reversed.
I really enjoy making cities in this game. My current city has been worked on for nearly 16 hours in 3x speed.
If there is a way to essentially copy and paste like a quarter of a world.

Version Number and Mods in use:
Release 707 (x64)
No mods
System Information:
I7 6700k @4ghz
32gb of ram
Gtx 1080

release-707 (x64)
@stonehearth/services/server/hydrology/hydrology_service.lua:331: water transients not yet implemented
stack traceback:
radiant/modules/common.lua:245: in function 'report_traceback’
radiant/modules/common.lua:492: in function ‘verify’
…arth/services/server/hydrology/hydrology_service.lua:331: in function ‘_link_channels_for_block’
…arth/services/server/hydrology/hydrology_service.lua:273: in function ‘_link_blocks’
…arth/services/server/hydrology/hydrology_service.lua:232: in function ‘_on_terrain_changed’
…arth/services/server/hydrology/hydrology_service.lua:92: in function <…arth/services/server/hydrology/hydrology_service.lua:91>

So after some more messing around with it. I got this error.
the game also became very stuttery. with Lua and Lua_gc using 45-95 and 10-55% of whatever the bar thing is near game speed.
Its literally unplayable now

Hey there @parandrus100, welcome to the Discourse :smiley:. Water is known to be buggy, but I don’t think I’ve heard it affecting renderer zoom before. Perhaps @Albert has more details…

The water implementation is unfinished and still has a few bugs (we’re working on a better system behind the scenes). I’m not sure how this could affect zoom though.

If you want to try and save the game you could try digging a channel and draining the water body to somewhere else. When the water level changes, it can kick the system to resolve itself.


Thats what I think caused it. I made a 1 block deep 1 block wide channel for the water to flow from the mountain to the ocean/lake. Apparently all the water flowed up and out however its left a water color over the blocks but not any actual depth to it. I then tried to expand the space the water could take up. but that ended up making water overflow somehow