LUA went through roof while merging 2 bodies of water

Summary: I had a an issue with the LUA lag. It was running 90% all the time and I couldn’t do anything. I tried to save and relog - even reset the game. Nothing.

Steps to reproduce:

  1. Mine the dirt / grass away so the water can run through
  2. I was digging two squares down, then the water turned bright blue (like the waterfall effect)
  3. Tried to block the water-pass with some random blocks. Didn’t help.

Expected Results:
That the water could run through my city.

Actual Results:
LUA lag, unplayable. Had to start over.


Sorry, I overwrite the save game after to try again. Ill post if it happens again

Version Number and Mods in use:
Update 21

System Information:
Window 10, i5 processor, 950 geforce

1 Like

How large was the mining area? The game dosn’t handle large mining areas very well.

It was small… like 8x8 blocks

They should put up a warning that water, so far, is unstable. Not a little, but a lot. Until they get to developing the waterphysics, it is best to steer clear of the blue stuff for a while.


Albert is working on water again. Currently, we have trouble merging two blocks of water, which is what’s going on when the water turns bright blue (overlapping blocks of water). Sometimes it’s fine! Sometimes it spits errors like crazy. Apologies for the inconvenience!




That makes sense, thank you… Glad you’re aware of the problem tho.
Never happend to me before tbh. And I build ALOT of rivers…

For a fact, its the first time I built the “river” 5 blocks wide… use to do 3 or 4. Maybe something you wanna test.