What is the alias for Carpenter's recipes.json


#1

The title says it all. @sdee Is there an alias? Because the recipe I have isn’t registering with it.

“mixintos” : {
“stonehearth/professions/carpenter/recipes/recipes.json” :
[“file(professions/carpenter/recipes/recipes.json)” ]
}


#2

/stonehearth/professions/carpenter/recipes/recipes.json. I’m also not certain if arrays work - or make sense at all.


#3

Oh, thats how I saw it in an exampel, I’ll change that.


#4

I really hate doing this, but I have no choice. My item WILL not show up in the game. COuld someone take a look?

https://dl.dropboxusercontent.com/u/73558230/hotairballoonmod.smod


#5

"/stonehearth/professions/carpenter/recipes/recipes.json" : "file(professions/carpenter/recipes/recipes.json"

Try that.


#6

Nope ;( Didnt work 20chars


#7

{
“type”:“recipe”,
“work_units” : 2,
“recipe_name” : “Falcon of Freedom”,
“description” : “To the mountains!”,
“flavor” : “Batteries not included.”,
“portrait” : “file(/entities/decoration/falcon_of_freedom/falcon_of_freedom.png)”,

Should read

{
“type”:“recipe”,
“work_units” : 2,
“recipe_name” : “Falcon of Freedom”,
“description” : “To the mountains!”,
“flavor” : “Batteries not included.”,
“portrait” : “hotairballoonmod/entities/decoration/falcon_of_freedom/falcon_of_freedom.png)”,

It is currently looking for the icon in hotairballoonmod\professions\carpenter\recipes\entities/decoration/falcon_of_freedom/falcon_of_freedom.png


#8

Still didn’t work. Do I have to create a whole new world?


#9

yes, don’t rely on loading saves


#10

Still doesn’t work. I don’tunderstand. It justdoesn’t show up in the recipe list.


#11

Edit: your falcon_of_freedom.json files point to mixins hotairballoon instead of falcon_of_freedom

falcon_of_freedom.png missing underscores

falcon_of_freedom_iconic points to hotairballoon

Ctrl H is your friend! :smile:

Edit works now.

You started as per my advice and named things hot_air_balloon, and then changed your mind because you wanted to call it falcon_of_freedom. Looks like you missed a few hot_air_balloons in your files. It’s an easy mistake to make.

I recommend Jofferson by @RepeatPan to avoid future headaches, or at least mitigate them.

Final Edit: When testing recipes, its always best to set the resource count to one and then increase the amount to what you want afterwards


#12

It still doesn’t work for me. Could you send me your edit?


#13

Still doesnt owrk withy your files. Reinstalling stonehearth…


#14

Just to prove i’m not trolling you:


#15

I didn’t realise how beatiful it is gunna look. I can’twait till it works for me XD


#16

Thanks for all the help btw!


#17

Resent the link just in case, and I reduced the cost down to one wood so you can test straight away


#18

All good, just needed to delete that outdated world, plus all of your fixes helped no doubt :smile:

Btw, howdo you get cloth resource, do you need a weaver? Does that mean bolt of cloth?


#19

yup, five bolts total


#20

Cool, once again, thanks! Now I have to make them fly around with a villager inside! Wanna help? JK I think I’ll add all of the ships and perfect themodels, then by then there will be a beefier modding api I can work with.