Can't figure out how to add new recipe

Hello everyone!

Once again I am continuing to develop my Magmasmith mod and have run into an issue. I am trying to add in a recipe to the class with its own category (i.e. “workshops”, “tools” etc.) but no matter what I have tried I can’t seem to make it show up in game. I have tried to look at how other mods do this (glassworks) but I can’t seem to recreate it correctly. If someone who knows how to do this would like to assist me I’d be very appreciative. I’ll attach my mod below.

As a side note, i have spoken with ACE and know they are developing a magmasmith as well and I have all the proper permissions to use the mod resources that I have appropriated. :slight_smile: (675.0 KB)

Anyways, thanks for taking a look!

1 Like

I think I might’ve found it :smiley:

You’re referring to the magmasmith’s recipes wrongly. Your file paths to the recipes folder inside your magmasmith folder but without going back:


When you use "file()" you need to tell it to go back a folder if you are inside a subfolder. Since your magmasmith_recipes.json is inside the mixins folder, it is looking for a jobs folder inside of it.
You should use ../ to go back a folder, so:

"recipe":"file(../jobs/magmasmith/recipes/magmasmith_obsidian_recipe.json)" should work.

Alternatively, you can scrap the"file()" and just do "/magmasmith_mod/jobs/magmasmith/recipes/magmasmith_obsidian_recipe.json"

But honestly I wouldn’t go that way, I would just add the magmasmith_recipes.json to the recipes folder itself and refer without a path. Much easier and consistent with other professions, where recipes and the recipes.json are together.

If you look into Glassworks, I only use the mixins folder for recipes that are from professions from Stonehearth itself; my own mods’s recipes (Glassmith) are all inside the jobs folder :slight_smile:


Hey @DaniAngione, I made that change you suggested, but the recipes are still not showing up properly. i took a look inside your glassworks mod and tried to recreate what you did in there but I think I’m missing something somewhere. I’ll post the new version of the mod. Could you take a look at it for me please? (675.2 KB)

Thank you,