What are the console commands?


#1

So I’ve played around with Stonehearth for a bit now, and recently I’ve been seeing people saying “the destroy command” or the “ib command” and I have no idea what’s actually being talked about. I attempted looking up the console commands myself, and I can’t seem to find a topic or a wiki page where they’re all collected into one coherent list. I don’t even know how to open up the console, and I’m not too keen on testing keys for fear of messing something up.

So, how do I access the console and what are the different commands I can use in it?


Unable to deconstruct a constructed door
#2

The console can be opened and closed by pressing ` [grave] or ~ [tilde]. That shouldn’t be a problem, as they’re both on the same key.

ib will instantly build the selected building, without any material cost.
destroy will destroy the selected object, whether that’s a creature, tree, a building, or anything else.

I don’t know if there are any other commands.


#3

For danish keyboards its " Æ "


#4

Ah, thank you very much.


#5

Thx mate, now the glitch is fixed!


#6

And what on the German keyboards? :smiley:


#7

Strg+Ö should do it on german Keyboards.
Or only “Ö” ? Not on my PC right now…


#8

what is the new button?


#9

left control + left shift + c


#10

You can type “help” into the console command and it’ll generate a list of them.


#11

Is there a way to manually save via the console? Because for some reason the game only lets me save the game once, and then the save button just doesn’t work.


#12

dont believe there is a way to do it through the console, but it is possible to save, if the deluge keys are enabled, by pressing F6 for save and F7 for load.

to enable the debug keys you simply have to put “enable_debug_keys”: true, right under your user ID in your user_settings.json found inside the stonehearth folder

for reference, this is a copy of what my user_settings.json looks like,

{
    "user_id" : "e91e8002-f84b-11e4-ad3b-3085a990d706",
    "enable_debug_keys" : true,
    "collect_analytics" : true,
    "alpha_welcome" : {
        "hide" : true
    },
    "enable_auto_save" : false,
    "renderer" : {
        "run_once" : true,
        "use_high_quality" : false,
        "enable_ssao" : false,
        "enable_shadows" : false,
        "msaa_samples" : 0,
        "shadow_quality" : 1,
        "max_lights" : 30,
        "enable_vsync" : false,
        "enable_fullscreen" : false,
        "screen_width" : 1920,
        "screen_height" : 1018,
        "draw_distance" : 1000,
        "last_window_x" : -8,
        "last_window_y" : -8,
        "last_screen_x" : 8,
        "last_screen_y" : 52
    },
    "audio" : {
        "bgm_volume" : 0,
        "efx_volume" : 1
    },
    "enable_64_bit" : true,
    "enable_lua_jit" : true,
    "tutorial" : {
        "hideStartingTutorial" : true
    },
    "mods" : {
        "homf" : {
            "customize_embarking" : true,
            "customize_immigrating" : true,
            "zoom_to_hearthling" : true,
            "pause_during_customization" : true
        }
    },
    "force_32_bit" : false
}

#13

Looking at your user_settings.json files, I didn’t really read through it, but your say false to force_32_bit.
I tried to change that to false, but the game doesn’t open when it’s like that…


#14

most likely be due to there being problems with the 64-bit, it works for some but not for others :confused:

note: the point of showing my user_settings.json was so you could see where to put the enable_debug_keys


#15

Right, I just put the enable_debug_keys, and it works… But the save says “incompatible save version” under “F6 Save”


#16

thats because you dont load a F6 save normally, instead you press F7. the whole point of these saves is for debugging (hence the reason they’re part of the debug keys) so dont rely on it (there can only ever be one at a time) to much.


#17

Nice a copy of console of Sims


#18

Bumping to provide a list of console commands as of Alpha 12


#19

By any chance was the console removed?
Or i am just stupid and forgot how to console.
I thought you had to press ` or a L but at a 90* Angle


#20

It’s Ctrl + c now. It was changed at some point.