What are the best basic modding / modeling tutorials?


#1

Hey (correct me if this is the wrong category)

I wanted to start modding this game but I don’t really know how to start. I looked at the modding category but didn’t find any tutorials. So my question: what are the best tutorials? or are there even any tutorials?

Greetings


#2


It’s a link to a past dev stream, now on youtube :slight_smile:. It is still applicable and have the basics covered.

EDIT: Look at the comment section for the actual starting time of stream.


#3

first, thanks for the recommendation. It really helped out, but:

This video is relatively old. Many things that are used from the original code (tried to copy all of it) aren’t in there any more. I tried to replicate it (there was a new place for the description for example with a path instead of a direct string. I tried to use that and just replaced the path with a string. I formatted it right but still, if I try to spawn the item, It won’t.

Version number is 21 (mod is loaded) and the item dropper autofills the mod + item name but if I press on the button, I don’t get the item

What am I doing wrong?

ReUp: Tutor-REAL.zip (5.6 KB)
the “mod” that I made
@thelegorebel sorry^^ Im kinda tired… Like my hearths about their clay beds :stuck_out_tongue:


#4

I don’t suppose you could .zip that instead of .rar? I can’t get inside of it to see the code.


#5

Well, #1. The version should be 3 (In the Manifest). It refers to the modding API version, not your mod’s version.

In the item itself…
Number two, the catalog does not go into the components section.

Number 3 You’re missing the entity data section, mob section (goes under components) and stacks info (also under components).

I’d recommend copying the stonehearth.smod, renaming it to .zip, then extracting it. Then you can look at all of the code in the game. For Instance, right now I’m comparing your code to the code for the basic oak log.

I don’t know what you’re trying to make, but I’m guessing it’s simple. Just find an item that’s like what you want to make, and copy it, changing what’s needed.


#6

I exactly did what she did in the stream [quote=“Stmpnk, post:2, topic:30350”]
Here :wink: Making a Reference Mod
[/quote]

But the problem is that there are things that aren’t there any more (Look at the video and start at 35:16 ). Look at the json file of the oak wood (I tried to reproduce it because thats the best way to memorize sth.)


#7

That would be because the video is old. Things have changed. For instance, recently the way the game looks at what an item is was changed, resulting in a 30%(?) boost in performance in that area, at the cost of most of the entity .json code needing to be changed to reflect that.

The best way right now, is to look at the currently existing code, and simply copy that, changing “oak_log” to “something_log” or whatever. That’s how I started modding.


#8

Jeah that really confused me because Stmpnk said, that…[quote=“Stmpnk, post:2, topic:30350”]
It is still applicable and have the basics covered.
[/quote]

But that doesn’t really educate. Sure, if you want to do really basic stuff and know sth about lua then jeah, you could do make good mods. But 1st. I never worked with lua before and 2nd you can look at examples from the game but you can’t work on mechanics that aren’t already in the game. You can’t get educated in making new mechanics with that method and that’s a problem


#9

Well, yeah. If you’ve never worked with Lua before, you’re gonna have a bad time trying to make something that’s not been done before. That’s a given, and not something that the stream can help you with.

If you want to make something completely new, you’re probably gonna want to learn a bit about Lua first.


However, you can still use the code that’s already there, and bend it and shape it in ways that seem new. For instance, I’ve got a mod I’m working on that uses the already existing campaign code, and (Just with json and going off of the vanilla campaign as an example) does something new with it. (No spoilers!)


#10

L.O.V.E.-in’ that game^^

Hm. I guess I should try to get the mod to run first and then look into the future… But I don’t really find the main failure. I can’t find any wrong / missing {[("… Hm I guess I have to forget that idea^^


#11

Did you change the version number to 3?


#12

I tried but it hasn’t changed anything. It would be weird if it wouldve done that. The mod is loading in the mods section and that’s the only time when this value is needed


#13

Works fine in my game. Stamped it into my world, I can see it. It doesn’t have the name or description, but that’s because your catalog section is in the wrong place, as I’ve said.


#14

Hm okay. In my game, It doesn’t spawn the item. I guess then it’s a problem with my version of the game


#15

That’s literally all I changed was the version number.