Weird Farmland Bug

I tried to make a sunken farm that looked like it was being irrigated by the nearby water and it ended up not wanting to till the land for farmers to actually farm

Steps to reproduce:

  1. Try and make a farming zone in the dug up land near the water

Expected Results:
Farmland in the green areas

Actual Results:
No farmland in the green areas

Farmers can plant and till in other places


Save File:
bug (9.2 MB)

Version Number and Mods in use:
Alpha 17 (DEVELOP 2998)

1 Like

Paging @sdee (or @yshan…) , here’s the save for the farming bug reported during stream 183.

1 Like

It seems I cannot open the attached file. Windows says it is invalid?

You would probable have to build a ladder down to it. I know it is only one block down but I know that Hearthlings have pathing trouble with these things. I have often build a statue base only one block high and the Hearthlings would not place it until I put a small ladder. I also made a blacksmith stand one block high and placed a forge on it. the Hearthlings would walk over to get to the crates behind it but the blacksmith would not craft anything until I build a one block ladder.

Since the farm is sunken by one block below the fence line this may be a similar issue.

The problem seems to have been fixed, I think the problem was that the farmland was too close to the layer above it. I moved the farm zone away one block from the grass layer and it worked fine, maybe the problem was not enough room for the hearthlings to stand and till the land near the grass layer?

1 Like

It should work? The save file is just in a zip folder

What fails is extracting the zip, @DerpTehTurtle. Could you try compressing it again and reuploading it?

I also get a message that the zip file is empty or invalid when trying to extract it, despite its size being several MBs. :sweat:

Save file reuploaded, i hope there’s no problems :confused: