Farmers still not correctly farming after update - Develop-2797


After 2795 where they were completely idle, I’ve loaded same save and as I saw mentioned elsewhere, deleted my previous farm plots and started new ones when their ‘harvests’ did not seem to be yielding anything at all even though they were going through the motions. In 2797 I now have the ghost remains of a gourd patch that my two farmers are stuck trying to replant them, I think. See screenshot - you can clearly see two ‘rotten’ gourd plants (I think the rest despawned) and one hearthling trying in vain to hoe an invisible plot. The other hearthling she’s just standing there twitching every so often like she’s trying to get out her tool but cannot move. I’ve saved and reloaded, rang the alert bell and ended it (this sometimes wakes hearthlings up out of weird states) and placed other crop plots (you can see them growing now in the background. Not sure what to do about this invisible one they’re stuck on…

Steps to reproduce:

  1. Run saved game w/ prev. bugged farmers from 2795
  2. Delete/Remove old farm plots / plant new ones
  3. Possible ghosted plot remains (not all of them did this, just one gourd patch)

Expected Results:

Plots should have vanished and new ones taken over with normal farming behavior

Actual Results:

Farmers planted new plots then returned to one of the old ones that had about half the gourds still present (no field graphic just the plants) and they are now stuck or idle around that.


I managed to finally catch an ‘engine error’ before this behavior started and though I cannot read all that code, I do notice some farming field stuff mentioned so I hope it’s helpful - attaching it as a wordpad doc.


Engine Error message copied from game shortly before odd farming / plot behavior started.
Screenshot of farmers trying to work an invisible gourd patch with two rotten plants.

Version Number and Mods in use:

Develop-2797 No Mods

develop-2797 error code get_farmer_field.txt (2.0 KB)

Thanks @Vexed. Something for @yshan to look at. Also, not sure what is going on, but the link at the bottom of your post doesn’t seem to be working, and while I took a look at the raw post content, I still am not sure why. Can you edit the post and try uploading the text file again?


@jomaxro- Re-uploaded both as the text file was acting wonky down at the bottom - I noticed. Does it work now?

1 Like

Looks good to me! (blah, blah, more text…)

1 Like


Restarted Save - Immediately upon load got another long engine error (attached .txt file again)

One of the two hearthlings then woke up and went to work the other fields. The female remained stuck. I assigned her back to Worker status, let her go a few min. and then re-assigned her back to farmer… she ran to help the other one - yay!

But nothing they harvested went to stockpiles. I visually watched them harvest the crops and put the baskets into their inventory (didn’t they just used to drop them on the ground and other hearthlings could haul them?).

Then they both went back to twitching and trying to hoe the invis. ghost plot of gourds …

In screenshot you can also see a partially plowed plot they have never completed. They made the movements and harvested the ones that were replanted (but no harvest yielded).

PS: I saw that ‘brown animal’ in the background and thought … “Cool they added sheep dogs for the shepherd!” and then realized it was just a sheared sheep who looks vaguely dog-like haha. :stuck_out_tongue:

develop-2797 error code _start_thinking_on_frame.txt (1.6 KB)

Done testing for tonight - back to sheep and hearthlings getting hungry again because corn isn’t being produced… some carrots managed to make it to a stockpile but I’m out of everything else.

I waited to see if anything would even out and correct itself after they seemed to get back to farming again for a bit… but no, they are still stuck on that gourd patch they can’t plant and still not pulling harvest.

On a side note, hearthlings are not all going to bed properly either, a lot of sleeping on the ground wherever they get exhausted. One was sleeping sideways in a bed but the rest slept outside. I have all comfy beds everywhere and though sometimes footmen get too tired after a fight to go all the way home and try to sleep wherever they are, I can use the green flag to force them back home… whereupon they promptly just sleep on the ground by the flag anyways.

hi @Vexed
Can you try removing the farms (click the red “remove” button in the UI) and then re-create them? The old farms might be in a bad state. Let me know if new farms have issues.

1 Like

@yshan - I can try again but I’ve already done that when I saw you mentioned it in another thread. That’s how I got the ghost gourd patch they are hung up on, by deleting the old ones… it left some sort of remnant behind causing them to try and replant it. They go to the other fields I started new but then go back to that one that’s still leftover and I can’t get rid of (see the screenshots).

I will recreate them all one more time tomorrow and report back.

If you still can’t get them to behave, can you upload the save? I’d like to take a look at it.

@yshan - Sure… I hope I did this correctly - zipped file of the save to google drive:

@yshan - Update today since I had a little time to tinker … loaded up a different save (newer one) that was also affected by the 2795 farming / harvest issues. Same results with this one as the one I posted.

Immediately upon deleting the old farm plots got a 3 page engine error pop up. I didn’t realize copy to clipboard only saves the 1st page, sorry. This is the only bit I got from the 3 pages:

develop-2797 (x64)
...h/components/farmer_field/farmer_field_component.lua:318: attempt to call method 'destroy' (a nil value)
stack traceback:
	[C]: in function 'destroy'
	...h/components/farmer_field/farmer_field_component.lua:318: in function '_unlisten_from_crop_events'
	...h/components/farmer_field/farmer_field_component.lua:421: in function <...h/components/farmer_field/farmer_field_component.lua:410>
	[C]: in function 'destroy_entity'
	radiant/modules/entities.lua:82: in function 'destroy_entity'
	stonehearth/call_handlers/entities_call_handler.lua:17: in function <stonehearth/call_handlers/entities_call_handler.lua:14>

The results in screenshot below of removing old farm plots / replant new… you will see the two farmers are randomly running back and forth between 4 small only partially completed plots and the remains of a wheat plot are still there too.

I’m going to start up a new game. I suspect this issue is probably only affecting saves from 2795 to 2797 but not sure yet. Will let you know.

So far so good on the new game for 2797, Looks like only farmers from 2795 updated to 2797 are borked. :slightly_smiling: