Water flowing over the edge of the map

I ran into an interesting problem. I wanted my town to look like it was along a coastline, but I couldn’t get the map to be positioned just where I wanted. After a while, I thought about just mining out the land instead of searching for hours for the perfect seed. However, part way through the mining process, I would get an engine error. I tried using “im” in the console instead, and the first time I got another engine error and the water didn’t move. The second time, this happened:

The water would fill the area about halfway before the game would stop processing stuff. I can still move the camera, and the speed in the bottom right is set to “play” (normal speed), but everything has just stopped (hearthlings, time, everything). I’ve waited about half an hour to see if it would start working again, but nothing so far.

EDIT: In the time it took me to type that, the water filled the space and the game is working again, but those waterfalls over the edge are still there.

Version Number and Mods in use: Alpha 21 with no mods


The devs are currently working on the water problems. The engine just can’t handle working with water except for in the simplest of ways. :merry:

Your idea sounds interesting, but for it to work right you’ll need to wait a while. Sorry.