Unable to switch to Cook class

I tried to switch a hearthling to the cook class, however, I am unable to do so despite having both the cook’s spoon as well as a level 4 farmer. I figured maybe it was an oversight and that I NEED specifically a level 2, so I made another farmer, got him to level 2, and still received the same alert that the prerequisites have not been met. I’ve tried with different hearthlings including the farmers themselves, but to no avail.
Steps to reproduce:

  1. Unknown how to reproduce.

Expected Results:
Be able to change a class to the cook, just the same with any other class.
Actual Results:
Unable to switch to the cook class despite having met the requirements. Requirements show in red, that they have not been met.


Version Number and Mods in use:
-524 (x64), No mods.
System Information:

Hey there @Gamma1227, welcome to the Discourse! Sorry to hear you are having issues promoting a farmer to a cook…

Can you upload the save game where this error is occuring so we can take a look?

To upload a save, locate the folder in C:\Program Files (x86)\Steam\steamapps\common\Stonehearth\saved_games (assuming a default Steam install), zip the individual save’s folder (not the entire saved_games folder), and upload it. If the *.zip is less than 10 MB, feel free to upload it directly to the Discourse. If larger, please upload it to a cloud storage site like Dropbox, Google Drive, File Dropper, etc. and post the sharing link here.

You know, I’m so sorry, disregard the post. You solved my issue with the word “promoting”. I could have sworn to have already attempted to change the farmer to a cook, but it is definitely working now! More than likely user error.

1 Like

No need to apologize! I’m just glad to hear that everything is working for you now. Have fun, and be sure to post again if you run into any new issues :smiley:.