Unable to start the game / No log


Steam says it’s “running” for maybe 5 seconds, then nothing. No Window, no nothing. Tried running it in compatibility and even with a fully clean download.


It doesn’t even produce a log file…

Versions and Mods:

Didn’t work the steam stable one and neither for the [latest] one. No mods apart from basegame.

System Information:

Windows 10 v.1803, GTX 950, External Monitor (two)

Have you attempted basic troubleshooting steps here: Crashing on start? Read this! UPDATED October 18, 2016

Tried compatibility mode, clean download, administrator, the firewall one, disabling fullscreen, windows troubleshooting, even updating the graphics card drivers


As unuseful as that might normally be: “It worked before”

The process crashes so fast that the normal performance analyzer can’t even connect to it… so here’s a screenshot of the debugging diagnostics from VS in case that helps any…

1 Like

Does it produce a crash.dmp file in the game folder? If not, but you are able to catch it crashing in Visual Studio, you should be able to save a dump from there (Debug -> Save Dump As…). A dump from either of those sources would help us figure out what’s wrong here.

Nope, no crash dump, no log file… the process lasts only about half a second with the debugger attached.

And at least VS 2017 (Community) doesn’t have the menu option you refer to :confused:

Hmm, I tested in VS 2015 Community and Save Dump As is just above the Options entry in the debug menu when the debugger is attached and the execution is at a breakpoint.

Something you could try is forcing it to run in 32-bit mode. In user_settings.json, add a top level entry saying "force_32_bit" : false.

Ahh, I see… The problem there is that the whole debugging only lasts less than a second and I don’t know how I would set a breakpoint in “foreign” code in VS.

Force 32 bit was false, did you mean true?

Also it’s almost 2am here, so the next reply will take a while :smiley:

Err, yes, I meant to suggest setting it to true. It’s really odd for it to quit and not trigger the debugger, write a crash dump, or start the log. That means it’s quitting intentionally rather than erroring out. Possibly unable to open ports of being killed by an antivirus.

I checked and made sure to set it to “trusted” in my anti-virus (was on “lightly restricted” before), but no dice.

Forcing 32 bit didn’t really change much, except that it now dies with an exception instead of exiting with code 0:
Unhandled exception at 0x72745F6D in Stonehearth.exe: 0xC0000005: Access violation executing location 0x72745F6D. occurred

(Also, ugh, discourse had me wait for the whole dump to upload before telling me it only allowed 10MB max…)

Memory Dump.zip (from where it threw the exception)

Thanks for that dump! The exception there is within the Steam API, as far as I can tell trying to initialize game-specific parental controls. Do you have any unusual parental control setup?

As in, for restricting access to children? I don’t have anything like that at all :thinking:

What surprises me more is, that it only happens with force 32 bit on… with seemingly no connection O.o

We’ll see what we can dig up, but as a last resort until we figure this out, you can run the game without Steam support by adding "steam" : { "enabled" : true } to your user_settings.json. Note that this won’t allow you to use Steam Workshop mods, and multiplayer setup is a lot less convenient.

It’s starting now, with "steam" : { "enabled" : false } :+1:

Also doesn’t work again when enabling steam again…

Here’s my settingsfile btw: user_settings.txt (1.6 KB)

did you ever manage to fix this? it seems you haev have had the same problem as i have now

It just worked again (even with steam) after another update, no clue what changed.

But try the disabling steam interaction thing (you can download the settings I posted to see how to do it).