[Tutorial][Alpha10] Larger Map Sizes

I figured out how to generate larger map sizes by editing a single file though doing this makes the game a bit unstable on lower-end computers.


self:set_game_options(session,response,options)wgs:create_new_game(seed,true)local generation_method=radiant.util.get_config('world_generation.method','default')if generation_method=='tiny' then tile_margin=0

Changing “if generation_method==‘tiny’ then tile_margin=0” to "if generation_method==‘large’ then tile_margin=#"
Replacing # with 2+ SHOULD generate larger worlds.

After you repacked the Stonehearth.smod with this change via 7zip, Winrar, or another archive program then the last thing you need to do is add a few lines to the user_settings file in your stonehearth folder.

“mods” : {
“stonehearth” : {
“world_generation” : “large”

And now if you generate a new world it should give you a larger map.


Nice detective work! I’d love to see a mod that implements multiple sizes of worlds, especially including worlds smaller than the default world, but bigger than the “tiny” world (so big enough to be interesting). Smaller worlds could really help players with lower-end PCs, and larger worlds could give hours of fascination to players with higher-end PCs.


Hello, I was following what you said to do when adding a few lines to the “User_Settings File” I get Error starting application It only happens when I add the lines to “User_Settings File” and can not seem to fine a way to fix it.

Could be where you pasted it; Can you paste your User_Settings here http://www.upaste.me so I can see them? Just paste the address bar and I’ll fix it for you :3

Alright I post my setting there hope you can see what I did wrong.

You never copied and pasted the link for me so I can see it lol

Unknown #21006 | Text - uPaste.me! (Sorry about that was thinking you owned the thing and it just showed up for you)

Try this; You had two “mods” sections and at the bottom you had a comma at the final line but there was no follow-up text so the config was reading more but there was none

I used the one you give but when I go to load it, it still says Error starting application same file

“Unknow JSON literal: true"stonehearth”:{“world_generation”:“large”}

The “mods” section, should be as @TheDerpySupport says in the first post:

1 Like

Oh I think I see what is wrong with my version hold on lol.

Try this version; I’m still new to modding Stonehearth so I have never added more than one ‘mod’ to the file

That work thanks for the help

I can’t understand what should I do there. Please help me!

Cant find this line:

self:set_game_options(session,response,options)wgs:create_new_game(seed,true)local generation_method=radiant.util.get_config('world_generation.method','default')if generation_method=='tiny' then tile_margin=0

Hey there! Your question is regarding finding the file location correct? What you need to do is…

  1. Open Stonehearth Folder
  2. Find Stonehearth/mods and open it
  3. Right-click Stonehearth.smod
  4. Open with… Winrar/7zip
  5. Locate said File
  6. Mod said file

I found file location but I can’t see this line.
Should I add line?

Hm…This line was back for Alpha 10 so let me spend some time to locate how to change this again and I’ll update the topic.

1 Like

Thanks I’ll wait :slight_smile: :slight_smile:

So it seems they completely changed the way the world generation works and moved the “tiny” world location to a whole new file on its own.


This is the new location; I havent examined this file yet but hopefully I’ll be able to figure it out.

1 Like

Thanks I’m waiting…

You found any way ??