They stop building after a few saves

Summary: When building, the people will just stop building.

Steps to reproduce:

  1. Start the building process
  2. For me, they would build after I had saved, quit, and reloaded the game, but only for a few times. After 3-4 re-saving (progress each time) and reloadings, they would just seem to forget about it completely.

Notes: I was just playing the game and my schedule doesn’t always allow me to have the game running for a few hours at a time.

Attachments: Save File

Version Number and Mods in use:
Release 707 (x64)

System Information:
Processor: AMD FX-6300
Memory: HyperX Fury 1866MHz 8GB (one stick)
Motherboard: ASUS M5A97 R2.0
Main Storage: a Samsung SSD (evo, I think) 250GB

Note that the save file has a 50 character max. (there are 29 characters at the point at which it is saved)


Cannot have a look at the game at the moment, but did you check that you have sufficient resources for the construction, or that there were not other constructions going on at the moment??

Definetly enough resources, they were almost done and only had the roof to finish. There was only one other, but they weren’t working on that one either. The two, just so you know, were: the inn and the end to one of the roads leading out of town. However, by that point I had started another project, but before I had started it they had not been working on the others.

What are they doing now? idling?

I’ll take a look at it probably 12 hrs from now - that’s my next free time when I can play, can only type now :smiley:

and chasing poyos and other nitpicky things. They aren’t mining because I paused mining. So yeah, please do go look next time you can. Thanks!

If any staff happen to be here faster, plz have a look :wink:


I took a quick look, but from what I see, there is totally nothing wrong or anything that could indicate a problem. It could be that it bugged out, but there is nothing that I noticed that indicates that. Sorry.

Moderators will come surely soon enough. @jomaxro will surely be able to help more than I.

I looked at this a week ago and totally forgot to reply. Sorry @Alacare!

So I could not reproduce the issue when testing. The buildings that were set to “build” (most seemed to be in construction mode still) all worked except one. The one that was stuck appeared to be due to it’s proximity to another building - no scaffolding could be built for the roof as the scaffolding would have been placed “in” an existing building. Adding manual ladders along the building worked.

Thank You! I’ll test it this weekend, and see if it works for me. And yes, I have a lot of plans still in planning mode. It makes since, because they are touching. Once again, thanks!