The Stonehearth Graphics Test Thread

I can’t minimize it! It worked great until I tried minimizing. Got a dialog saying “error == GL_NO_ERROR.” False reporting? And then this dialog box.

Then it shut down and windows tried to ‘find a solution’ but couldn’t.

Windows 7. Intel i5. 8GB ram. HP Pavilion dm4. Intel HD 3000 graphics chipset.

On “old” errors:

  • No Z-Fighting on single models.
  • Resizing does not crash the program.

Only the “!readPending_”-error continues to appear every now and then as still I can see yellow dots in trees and related shadows.

New errors:

  • Shadows are “flickering” (looking like moving waves).
  • Sometimes shadows behave strange at the hands (seed 666):

… triangles:

… “jumping”:

  • Z-Fighting still exists between models:

P.S. My FPS are now down to constant 60 (from 400 in Graphics Test 1).

I had the test running a couple of times then when I tried to start it up again I got the !readpending_ error again :disappointed:

Also I saw the same shadow triangles that @voxel_pirate did.

Perhaps a new thread for this new versions issues? So the team can tell what is about the new one and can collate newer issues more easily?

A few overlapping trees cause z-fighting, and some trees grew on rocks, although that’s not really a graphic issue and may be intentional. Other than this, it runs, generates, and looks fantastic!

Actually the bug-reporting category was introduced last time. Let’s get used to it and report bugs there. If a bug is not yet visible, create an entry. If it is there, just like the post.

1 Like

I have had a bug where at any given time, the game will just exit itself out.

1 Like

Are you clicking the red cross in the top right corner again?

But in all seriousness, I’m not sure if this has been discussed before, have a look in the bug report category, if it hasn’t then post a thread following the template with as much info as you can!

1 Like

Had the same. At one point in time I was zooming in to see my worker and was “stucked” in a tree. While I was trying to get out the program turned black and Stonehearth closed without an error.

@Prof_Crafter could you take a look into this post and see if that is what you have experienced?

The graphics test does not install for me. It hangs at “Installing Stonehearth” indefinitely. I had the same issue with the prior graphics test. There’s no popup or error message or warning, just an indefinite hang.

System information:

Windows 7 Professional Service Pack 1

8 Gigabytes installed RAM
64 bit operating system
Intel ® Core™ i5 CPU 750@2.67GHz

display is 1900 x 1200

Graphics card is GeForce GTX 660ti

Only “error” from application logs is
Faulting application name: daemonu.exe, version: 9.3.16.0, time stamp: 0x525f66c3
Faulting module name: ntdll.dll, version: 6.1.7601.18247, time stamp: 0x521ea8e7
Exception code: 0xc0000008
Fault offset: 0x00082915
Faulting process id: 0x908
Faulting application start time: 0x01cef0922a7b9380
Faulting application path: B:\Program Files (x86)\NVIDIA Corporation\NVIDIA Update Core\daemonu.exe
Faulting module path: B:\Windows\SysWOW64\ntdll.dll
Report Id: 8ed424b7-5c85-11e3-96ca-0014d123256a

Hi all,

Not sure where to post this but here it is. I had a surprising amount of lag with this test. It doesn’t have an fps counter (that I know of) but if I had to guess it would be 25-30. This is odd considering my laptop should be capable.

Asus G74sx-TH71
Windows 7
I7 - 2670 QM, 2.2Ghz
12 GB RAM
GeForce GTX 560M - 3GB

Alright, so I found a weird little thing: when I fullscreen the Test, the loading screen briefly disappears and the world itself shows in the window. I’m not really sure how else to describe it, but just click maximize on the Test window and see for yourself if it happens.

Also, is it intentional that the closer to the top of the screen you drag from, the faster the world pans? Because I find that, if I shift-click and drag down from near the top of my window, the entire world zooms past my camera and I’m left in a world of infinite darkness.

Not sure if someone has already said this, but if you zoom in real close inside a tree…


This happens.
This obviously shouldn’t be a top priority, but I do think that it should be looked at, maybe just get rid of the tree “fragments” all together?
Also, are you guys planning on adding some character to the ground? Wide open spaces are nice for building, but just the plain shades of green are kind of dull.
On a positive side, I love the fact that you guys are releasing these, I’m so pumped for the early release, and I hope you guys keep on giving us amazing stuff.

This is a quote form the Developer Post today, so the devs have acknowledged this issue and will fix it in due course.

thanks… i logged a report for this issue here

thanks… feel free to add a “like” or any supplemental information to this report

1 Like

!readPending_
under Assertion Failure

2 Ghz dual core AMD
8 GB RAM
Windows 8.1
1680x1050 res
ATI Radeon 3400

I just get a black screen and then it shuts off after error. I do see the custom cursor though (which looks nice). I should point out that I am running an out dated graphics driver due to the Windows 8 driver for the integrated graphics chip has no OpenGL support but, I did go ahead and test with the new as well and no difference was made.

I am running as Administrator and I have tried compatibility mode.

Game Runs much better, Cpu usage went down to about 30% from 80-90%, from the previous test.

As mentioned before shadows are messed up, very saw like from certain angles, also notices weird shadows (I believe)
on the characters arms. They only showed on certain angles of the character. Did not really notice those anywhere else.

I5 3570k
gtx 670
8gb ram
windows 7

I also enabled ssao blur and ssao. Set msaa to 16 samples and shadow resolution to 4096. V sync off.
Retried with original setting but weird shadows remained on character (maybe even worse in a way).

The second graphics test crashed while scrolling through the world.

Naam van toepassing met fout: Stonehearth.exe, versie: 0.1.0.55, tijdstempel: 0x529e37d4
Naam van module met fout: KERNELBASE.dll, versie: 6.1.7601.18229, tijdstempel: 0x51fb1116
Uitzonderingscode: 0x80000003
Foutoffset: 0x00013219
Id van proces met fout: 0x1ae4
Starttijd van toepassing met fout: 0x01cef0ce2a469eb8
Pad naar toepassing met fout: C:\Program Files (x86)\Stonehearth\Stonehearth.exe
Pad naar module met fout: C:\Windows\syswow64\KERNELBASE.dll
Rapport-id: c621f27b-5cc1-11e3-ab36-efbf1924ce7e

Sorry for the log not being in english.

The Z-fighting does not seem to be resolved completely. I had multiple instances of trees clipping together with one or more sides and they had the bug.
Here is the link to the image: Imgur: The magic of the Internet

All I get is a black screen as follows:

The text is there, and highlights appear around bushes and such. I can move the camera around, as the highlights change position when I press and hold the right mouse button.

2 Likes

@DruidTC could you open a thread in the bug-report category and add some details? Seems like you are the second one with this bug… but no details yet if it can be reproduced, etc.

2 Likes