Stonehearth Opening Failed

Stonehearth partially loads.
Steps to reproduce:

  1. Open Game (Tried Steam, and Desktop Shortcut.)

Expected Results:
Opens normally.

Actual Results:
Black screen, no noise, mouse icon works, but menu/menu graphic don’t load.

I have a few mods, it could be them. Mod I have installed:

  • Magic Combat
  • Wizard Quest
  • [ACE] TMD - Tier (1,2,3) Buildings [3 Different Mods]
  • Nordlingmod [KINGDOM] [ACE+Vanilla]
  • Even More Starting Hearthlings
  • Building Colors
  • Extra Map Options
  • Swamp Biome + Firefly Clan + Beast Tamer
  • Missing Weapons
  • Swords AND Plowshares
  • Authorized Community Expansion (ACE)

I’ve also uninstalled and reinstalled the game, then verified file integrity, yet it still doesn’t work.


Version Number and Mods in use:

  • Don’t know how to check the version.
  • 11 Mods

System Information:

  • I have a low-quality laptop from a few years ago, and when I was running mods before the latest update, it was fine. It runs very well without mods, but when I removed them it still didn’t work. I redownloaded all the mods after the update. (;=new line)
  • Inspirion 5555
  • AMD A8-7410 APU with AMD Radeon R5 ; Graphics 2.20 GHz
  • 6.00 GB (4.94 GB usable.)
  • 64-Bit

If it’s the mods, I’d like to know which ones I need to redownload, and which ones to completely remove.

Try pressing F5 several times, it may work
The only mod I dont recognize is the missing weapons one


what nightlancer said, except try it ONCE first before you spam F5 like your life depends on it.

I tried, didn’t work.