Stonehearth Is Not Launching

So, I Bought Stonehearth Yesterday, Tried Uninstalling It 3 Times, My CPU / Video Card Is Intel ® HD Graphics 4600, Memory Is, 73.9, Out Of 465 GB. I Have Also Tried Launching Steam As Administrator To Run It.

And Yes, My CPU And Video Card Are One In The Same.

Hey, @homer4me. Welcome to the discourse!

Does the game launch at all and then crash to desktop or does it just fail to load?

Do you happen to have Lavasoft installed on your computer? (It is known to cause problems with many applications, including Stonehearth)


No, I Do Not Have Lavasoft, And It Just Fails To Load.

Can you upload your Stonehearth.log file? The default location is C:\Program Files (x86)\Steam\steamapps\common\Stonehearth assuming a Steam install.

Edit: Also, can you confirm if you have attempted to install any mods, and if there is a crash.dmp in the same folder as the stonehearth.log, please zip it and upload it too.

1 Like

I Have Not Downloaded Any Mods, And Here Is The Log File. (I Cannot Upload A Attachment Since I Am A New User.) 2016-06-04 13:46:33.567410 | server | 1 | app | Stonehearth Version (x64)
2016-06-04 13:46:33.569410 | server | 1 | core.config | user id is 0fd4ffc4-2a72-11e6-8d02-40f02f7fa3e1
2016-06-04 13:46:33.569410 | server | 1 | core.config | session id is a8b1f7e4-2a84-11e6-8664-40f02f7fa3e1
2016-06-04 13:46:33.569410 | server | 0 | core.system | Initializing crash reporter
2016-06-04 13:46:34.142443 | server | 0 | | lua jit is disabled
2016-06-04 13:46:34.152444 | server | 1 | resources | Module rayyas_children_ui version 2 is deferred load)
2016-06-04 13:46:36.810596 | server | 1 | resources | Modules are verified pristine.

Also I Do Not See crash.dmp

Hmm, so that’s the entire log file? Would you mind copying your user_settings.json file to the forums?

Also, you should be able to upload files now :smiley:.

Well, It Says I Cannot Upload Json Files, So I Guess I’ll Have To Paste It, Here It Is.

“user_id” : “0fd4ffc4-2a72-11e6-8d02-40f02f7fa3e1”

Not being able to upload json is expected, that is a restricted file type. Anyway, please try replacing the file with the following (be sure to add your user_id)

	"user_id" : "YOUR ID HERE",
	"collect_analytics" : true,
	"enable_auto_save" : false,
	"renderer" : {
		"run_once" : false,
		"use_high_quality" : false,
		"enable_ssao" : false,
		"enable_shadows" : false,
		"shadow_resolution" : 256,
		"msaa_samples" : 0,
		"shadow_quality" : 1,
		"max_lights" : 30,
		"enable_vsync" : false,
		"enable_fullscreen" : false,
		"screen_width" : 1920,
		"screen_height" : 1018,
		"draw_distance" : 1000
	"audio" : {
		"bgm_volume" : 0.6,
		"efx_volume" : 0.6
	"enable_lua_jit" : false,
	"force_32_bit" : false,
	"language" : "en"

Odd, It Is Still Not Working Even Though I Tried That, Any Other Ideas?

Hmm, can you look at the log again? If it has changed, please copy it here again. If not, please let me know and I’ll try and think of other things to try.

stonehearth.log (825 Bytes)
It Seems Only The Session ID Has Changed.

Yeah, the session id will change each time you run the game. Give me a few minutes, going to do some research on my end. Will be back!

Edit: @homer4me, unfortunately, I’m not sure what else to suggest. @8bitcrab or @relyss might have some ideas - if not, you’ll likely need to wait for @Albert to be back at work on Monday.

hmm… @homer4me perhaps take a look through this thread,

other than that, as @jomaxro said, best bet is to wait for Albert…

1 Like

Ok, Thanks For Trying You Guys! I Appreciate It!

1 Like

I’ve never seen a stonehearth.log file that was so short.

Exactly what happens when you launch? Do you get a black screen that doesn’t close until you kill it?

What security / privacy / anti-malware / anti-virus software are you running?

Can you try updating your drivers from this link?: