(SOLVED) My Game is Unplayable (literally) Alpha 21 Game Breaking Bug. Black Screen

This started about a week ago, I had gotten really far into the game, about rainmun. Sadly, this game got corrupted and so I had to delete it. I thought it wasn’t that big of a deal and I can just start again. I opened stonehearth, randomize some hearthlings and chose a spot on the map. As soon as I pressed confirm, my entire computer froze. The cheery music still played and the game was still there just, but it looked like a screenshot. The game wasn’t moving, I couldn’t move my mouse either. I tried Alt f4 but no luck. Ctrl-Alt-Del didn’t do anything. I tried pressing the windows button to no avail. The only way I could close out of the game was to completely shut off my computer and turn it back on using the power button. This pattern repeated about 2 more times until I started to look up a solution. I found the one that was pinned via Helusay but none of what he/she listed worked. I browsed the internet for awhile, trying various things. I tried reinstalling, going into the game files and deleting certain files/applications that might cause an issue but none of these things worked! Instead, these “fixes” made my game crash right after I launch the application. From my browsing I haven’t found anyone else who has had such issue. I absolutely adore the game, and I would love to go back to playing the game. I’ll be giving feedback and updates to what has happened on this issue. I’ll also be posting this on the Steam Stonehearth Discussions .

Computer Specs Below-
Alienware Area 51
Windows 10
Intel Core i7-5820K CPU @ 3.30GHz
16 GB
64-bit Operating System

Updates will be posted below-
The first main factor causing this bug is that your GPU Temperature is too high, try turning your fan speed higher using the MSI afterburner program. The second main factor causing this bug is that your Graphics card may be out of date. Download your new one here: Download Drivers | NVIDIA

Sorryto hear that you’re having the issue, i’ll page the @moderators so they can take a look

For now though, could you perhaps upload your log? It should be where the game is installed named something like ‘stonehearth.log’ or something

That would help figure out what happened

Hi @jaxcalop, welcome back! Sorry for the delayed reply, I’m currently on vacation in a different time zone, and jet lagged, so I’m a bit off.

As to the issue, I don’t think I’ve seen this one before. Definitely odd that it started “about a week ago”, as there weren’t any Stonehearth updates at that time. Like @Hyrule_Symbol said, a copy of the stonehearth.log file may be useful. The log is overwritten during each start, so the best time to upload the log would be immediately after rebooting from the full computer freeze. It can be found (by default) in C:\Program Files (x86)\Steam\steamapps\common\Stonehearth. Once we have the log we can hopefully provide more specific troubleshooting steps.

1 Like

@jaxcalop did you see this thread in Steam? : Fullscreen to black screen on close!! :: Stonehearth Bug Reports

Are you playing with fullscreen, do you have V-Sync enabled?

I’ve seen something similar to this in the past with other games. Everything is continuing to run in the background (sounds), but video completely stops or the screen goes black. I found my issue was temperature throttling by my GPU. The card was hitting it’s thermal safety limit and shutting down all video output while all other processes were running in the background. I’m not familiar with the alienware line anymore, but if this is on a laptop your chances for this to happen can be fairly high.

Only suggestion I can offer on experience is try to monitor your GPU temp with MSI Afterburner and see if that is the case.

Hope you get it fixed mate.

stonehearth.log (3.8 KB)

First of all, thank you all for such support so quickly. You’ve really helped me a lot!
Second of all, i tried turning my monitor off and on like Ferran said. Sadly, this didn’t work but i do appreciate you trying to help. This community is great! I Uploaded the log as the first thing after the reboot. Hope this helps!

Edit: I’ll try adjusting my GPU temperature next

Your graphic drivers seem a little outdated, you can update them from here: Download Drivers | NVIDIA

1 Like

thank you everyone for your contributions!
There were two main factors that were causing this issue

  1. My GPU temps were too high so I increased my fan speed
  2. My graphics card was out of date, meaning it didn’t like to play well with stonehearth
    My new log will be posted below

stonehearth.log (12.0 KB)