[SOLVED] Annoying Soundloop bug (Asus Xonar)

Hi, I found one very… very… annoying bug.

Everytime I shutdown Stonehearth strange soundloop starts and it can be only stopped by restarting the whole computer.


Windows 8.1 Pro 64-bit
i7 2600k 4.6Ghz
VTX3D Radeon HD 7970 X-Edition
Asus Xonar DGX 5.1 Soundcard

Possible solutions:
1. Turn off GX-mode (below) and problem should be fixed.

2. I recommend installing these custom UNi-drivers for your Xonar. Remember check “Low DPC Latency” from installation-window and of course after the installation uncheck the GX-tick just in case.

Here you can find some quides for removing old drivers and cleaning registry etc.

I can confirm this bug for version r41 using a similar setup. Also using Windows 8.1 Pro 64-bit and I also am using an Asus Xonar DGX sound card. Latest UNi Xonar Drivers installed.

Ah, this was reported over at the Curse forums, I believe the issue was resolved with an update to the drivers, although you say you have the latest?

The problem seems to be isolated to Xonar sound cards.

Read through the thread here and see if there are any steps to resolve the issue:


1 Like

Yeah, my problem was also linked to Xonar-soundcard (DGX).

Turn off GX-mode (below) and problem fixed. = )

Picture here


Great to hear that you managed to fix it!

@layl any progress?

I haven’t tried since but GX mode is already disabled for me. One thing that could be causing it for me is that it seems my onboard sound is still enabled and I have to disable it in BIOS.

Brilliant! This was annoying the pants off of me. Thank you!!

1 Like

Warning for Xonar users: it appears if the GX button’s text is white, it is off. If the text on the button is dark, it is on. Holy hell that’s confusing.


Ever since the very first Alpha build, I’ve found that upon exiting the game, my soundcard (An Asus Xonar D2X) just starts blaring out some random feedback/loop noise (like a jackhammer). This persists until I either restart or disable and re-enable my whole soundcard.

It still persists in the latest steam build. Is this a known issue?

I don’t think many people use sound cards so it may not have been reported. I believe a majority of users use the motherboard’s sound chip. Just to be clear when you say sound card you mean connected through a PCIE bus right? Are you on latest drivers? Does this happen with any other game?

Yea its a PCI-E card. This happens with no other game since I’ve had this card (over 2 years) and drivers are indeed up to date.

I believe so, check out the earlier posts in this thread and see if it solves the problem :slight_smile:

Everytime I exit the game it bugs the soundcard. It’s pretty annoying as I have to restart my computer.

It’s hard to explain, but when I exit the game I get this continuous looping sound that annoying as heck. Is this a known bug?

This issue was known a long time ago. Let me see if I can find the thread…

Edit: I merged your topic here. I don’t know if your soundcard is mentioned in this thread but the symptoms are the same.

Thank you Relyss! I too have the Asus Xonar, I’ll address the problem… but most threads from other games mentions “disable GX”.

1 Like

I recommend installing these custom UNi-drivers for your Xonar. Remember to check “Low DPC Latency” from the installation window and after the installation uncheck the GX-tick just in case.

Here you can find some guides for removing old drivers and cleaning registry etc.

I’ve had this problem too some versions ago. I got it fixed by unchecking the GX, but Low DPC UNi-drivers will completely remove the GX-feature and improve drivers overally.

Wow Luukku12! It seems to have worked. I installed the driver, launched Stonehearth, quit, and no annoying sound! So incredible lame of Asus for not fixing this!