Sound problems with Stonehearth

After the games initial launch a silent buzzing can be heard, which is caused by my soundcard. But this buzzing does not occur with any other game than Stonehearth, so I think we are dealing with a optimizing error of some sort.

Steps to reproduce:

  1. Use my soundcard
  2. Use my microphone jacks that were never really designed to be used
  3. Play Stonehearth

Expected Results:
Clear and smooth audio with no background noises

Actual Results:
A faint, but annoying buzzing sound in the background



Version Number and Mods in use:
Newest version, no mods

System Information:


	Sound Cards
		NVIDIA High Definition Audio
		NVIDIA Virtual Audio Device (Wave Extensible) (WDM)
		Realtek High Definition Audio
	Playback Device
		Speakers (Realtek High Definition Audio)
	Recording Device
		FrontMic (Realtek High Definition Audio)

Operating System

Windows 10 Home 64-bit


Intel Core i5 4460 @ 3.20GHz	38 °C
Haswell 22nm Technology


8,00Gt Single-Channel DDR3 @ 798MHz (11-11-11-28)


Acer Aspire TC-705 (LGA1150)	38 °C


Acer K272HL (1920x1080@60Hz)
2047MB NVIDIA GeForce GTX 750 (Sapphire/PCPartner)	38 °C


119GB KINGSTON RBU-SC150S37128GD (SSD)	36 °C
931GB Western Digital WDC WD10EZEX-21M2NA0 (SATA)	39 °C

Optical Drives



Realtek High Definition Audio

Did you hear the buzzing with previous versions?
Are you on A21-r707, or on A22-r729?


0.21.0 (release 707) x64 build

If that’s what you asked

Yes, I bought this game in 2, jun 2016 and my current PC was bought in September 2016, and the problem came with my new PC.

If you are indicating that there is a newer version, then why hasn’t my steam downloaded it yet? (I have automated updates)


Because the new version is an unstable release, which is in a different branch.
To change to the unstable branch:

  1. Go to your Steam Library and right click on Stonehearth
  2. Select “Properties” from the dropdown menu.
  3. Hop on over to the “Betas” tab
  4. In the “Select the beta you would like to opt into:” dropdown, choose "latest – The latest branch"
    If you want to return to the stable branch, select “NONE – The regular version of the game.”

This doesn’t guarantee that your issue will get fixed. If you had it happen since before, it will probably be the same in the latest version. The thing is we updated our sound library in this latest version, so we are searching for bugs related to sound. So far the fault seems to be the hardware. I’ll ping @jamiltron in case he has any idea.

1 Like

Sorry… I tried the latest build and the sound did not go away

1 Like

Does the buzzing still happen if you go into the options and turn both the music and the effects down to 0?

Yup, I even turned the sounds off from windows sound mixer while having sounds turned off manually in the game menu, with no effects whatsoever

So to confirm you hear nothing from Stonehearth, nothing from the OS, except the buzzing described above?

Yes, that’s correct. [to fill 20 words limit]

And this also occurs if you plug in headphones before you start? If you do plug in headphones - does buzzing still happen out of the speakers, or the headphones?

I tried Stonehearth with my brother’s usb headset and there was no buzzing, so it has something to do with the way stonehearth manages sound, and the way it manages is not optimal for my sounds-card’s in- and out-jacks. Cause there is no such buzzing with any other game I have played other than stonehearth. (I have 50 games in steam, some fullscreen some not) And literally as I am writing this I tested stonehearth with fullscreen off and on with no difference in the buzzing except slight pitch change.

If you plug in headphone with a normal audio jack (not usb) - turn the sound completely down on the OS level, do you hear the buzzing from the headphones, the computer speakers, or not at all?

Also, in your initial configuration - is there a difference in the buzzing sound between playing the game in vsync and not in vsync?

Thank you!

Oh also, what do you mean in your initial post that your microphone jacks were never really designed to be used?

With OS sounds off and game on the buzzing can be heard. I have speakers which are audio jack connected and they also buzz. WHAT DA FUG Turning vsync on got rid off the buzzing… Isn’t vsync a graphical setting? Please explain : D

PS. My Azer pc is not optimized for audio jack usage: other components stacked on the inner wires of the jacks inside the computer, causing the jacks to capture slight electrical disturbance

Ok, I was suspecting it was a hardware issue. Sometimes the way hardware is installed into a machine certain components can cause line interference with other components. This sometimes happens with the graphics card or sometimes even a power source causing an interference with the sound setup. My understanding of why vsync can alleviate this is just that it potentially causes a reduction in the interference, but isn’t an actual remedy for the problem.

The fact that you have wires causing electrical disturbances further indicates that this is a hardware issue. Why only Stonehearth thus far has seemed to affect your sound I am unsure of, but my only suggestion would be to correct the electrical disturbance issue you describe above and see if that helps.