[Res] Unremovable ladders and unlimit amount of removal buttons bug


I played the early alpha version (2494) and encountered a bug where ladders can’t be removed enterily.

Steps to reproduce:
Start a game
Build ladders halfway in a cliff
After the ladders have been constructed, extend the ladders by building second ladders on top of it
Click one of the remove buttons (yes now there is 2). Now a villager removes only the most top ladders.
Try to click the second remove button (there are still 2 even accepting the fact that other ladder was removed) -->nothing happens.

After this you can build the top ladders again and a third remove button appears. Now you can remove it again and build a another one. I tried to repeat this 4 times and here is the outcome:


This happens for me too. Good description Majis. Someone should move this topic to Support/Active Bugs.

1 Like

That is actually kinda fun :slight_smile:

For those who want to get rid of the ladders:

  1. Click the ladder
  2. Open Console (ctrl+c lastest build)
  3. Type destroy
1 Like

I can confirm this too, I saw it the other day.

1 Like

Is this still happening? I tried it on the latest build and it seems to work fine. Thanks!

I tested it too and it seems to work. :thumbsup:

1 Like