[Res] Promoting Footman Causes Infinite Error Loop

This is in Alpha 4 build. After a worker picked a sword up the game just starting listing a bunch of errors and the number next to the " ! " in the red diamond just kept going up. Then after the number got to about 4000 I could close the window but the game was very laggy but I could scroll around the map without lag. I could not access the menu to save or exit the game. Eventually the game just crashed.

hi there @Aklick01… any chance you can reproduce (and list) the exact steps? or capture a screenshot perhaps?


I believe this is the bug @sdee was mentioning that ended up in the release. If so they are working on fixing it now.


Just thought I’d mention that when a footman joins your group from a caravan. I believe the same bug occurs although you don’t get the red screen but the game slows down so much that it nearly stops. I tried to save and load but the game crashed on loading that same save…

The second time the list appeared a bit later then when it happened the first time.
but when I did got the errors I just simply clicked on the citizens list then a worker, promote, footman, and finally approve. And once the worker picked up the sword the list of errors appeared.screen shot of list of errors, that number in the top left just keeps going up

Yeah the same for me. When I had a footman join me I got the error message

I can confirm that the footman joining you settlement slows the whole game down to a standstill, and a save/re-load causes unending errors

@Lomico Try updating it there was a hotfix… and although I still feel the footmen aren’t working properly this error seems to be solved.

@woollysmash sweet, hadn’t seen that. and yeah, my save loads fine now! no slowdown either

1 Like

Edit* Lomico Ninja’d it haha.

Here is the link where we discussed it and the fix… Click me!

Sorry about this one; it crept into our last release at the last minute. @Albert heroically smashed it last night, so it should be fixed in the current build.