[Res] Frozen Hearthlings in chain (save games included)

I seem to be getting this at random but one hearthling will completely freeze up with whatever it is doing ( no movement at all). once this happens others will start to freeze and sieving then loading will not correct the problem. it just causes a chain reaction making more hearthlings freeze up and completely stop

EDIT: only 4 of my 21 hearthlings are working and moving still. my 4 guards and a normal worker… even the new hearthling I got froze up after appearing and running to my banner

this is the error I get:
release-465 (x64)
stonehearth/services/server/ai/ai_service.luac:116: error in args passed to should_start_thinking: missing argument “ghost” of type “userdata: 0000000005A6D5E8” in “[u:6712 place plantable item]”.
stack traceback:
[C]: ?
[C]: in function 'error’
stonehearth/services/server/ai/ai_service.luac:116: in function 'report_error’
stonehearth/services/server/ai/ai_service.luac:148: in function <stonehearth/services/server/ai/ai_service.luac:103>
[C]: in function ‘start_thinking’
…onehearth/services/server/tasks/run_task_action.luac:26: in function ‘_start_stop_thinking’
…onehearth/services/server/tasks/run_task_action.luac:50: in function <…onehearth/services/server/tasks/run_task_action.luac:48>
[C]: in function 'fn’
stonehearth/services/server/threads/thread.luac:109: in function 'private_msg’
stonehearth/services/server/threads/thread.luac:168: in function '_dispatch_messages’
stonehearth/services/server/threads/thread.luac:128: in function <stonehearth/services/server/threads/thread.luac:123>

[C]: in function 'execute’
stonehearth/ai/actions/idle_top_action.luac:5: in function <stonehearth/ai/actions/idle_top_action.luac:3>
[C]: ?
[C]: ?
[C]: in function 'run’
stonehearth/components/ai/ai_component.luac:186: in function '_thread_main’
stonehearth/services/server/threads/thread.luac:90: in function <stonehearth/services/server/threads/thread.luac:89>
[C]: in function 'xpcall’
stonehearth/services/server/threads/thread.luac:89: in function 'f’
radiant/lib/env.luac:8: in function <radiant/lib/env.luac:8>

EDIT: I hope this works, here is the folder with the saves in it:
Meet Google Drive – One place for all your files


Hey there @Fralee, welcome to the discourse! Thanks for posting this bug.

Do you by chance have a save game for this which you can share? If you do, it would be located in (assuming you installed via steam) in C:\Program Files (x86)\Steam\steamapps\common\Stonehearth\saved_games. If you could upload that to something like Dropbox or Google Drive, and post the link here in this thread, that is usually helpful to the developers as they can see the issue first hand, and not have to try and make it happen to them first.

I got better! I have 3-5 different save games from different attempts. ill upload them in the morning once I am able to


alright got the link to the saves, theres 3-5 in there

Thanks @Fralee! I am going to ping @yshan, @Albert and @sdee to see what they can do with this.

still new to this set of fourms…

im guessing that saying someones username dose something to drag them here?

Depending on user preferences, it can do a number of things. First, it will cause a small blue icon to appear on the user image in the top right, with a notification that you were “mentioned” in the thread. That would happen to everyone. If you set it up to do so, you can also get emailed when you are mentioned. Mentioning the devs in a thread can be helpful so they don’t have to read every single thread that comes up, especially if we (the fans and moderators) can deal with it ourselves. Allows them to keep developing and not focus so much on reading.

that’s good to know! thanks for the info :smile:

1 Like

Hey there! Got the very same problem. Only when I try to load a saved game. I tried to change settings, tried to restart… but nothing helped. The error looks quite the same.

Actually I got about 19 error messages in a few seconds and the most of my hearthlings freezed.

I really hope that there’s some solving possibility, cause I really love this game!! :smiley:

it seems to start to get worse after loading a game
but I hope its fixed soon since its gamebreaking atm

has this one been fixed?

I think so :smile_cat:

1 Like

I think it has my saved game that had this problem now works!

1 Like

Yep, I believe they mentioned some bugs that look like this one and have been fixed on release 472. Moving to resolved.

1 Like