[res] Crash On Start (Assertion Failed)

I have seen simular posts to this one, but none exactly the same. I have tried both branchs on steam to update from and the game still crashes on start with the same error message. I have…

  • Re-downloaded / re-installed the game 2x
  • Switch Beta Branch with Common Branch
  • Reinstalled my Operating System
  • Constantly checked the forums for simular issues.

I still Get the same Error! The error is a pop up that says “Assertion Failed: false(…\…\…\…\…\source\client\renderer\renderer.cpp:1980)” My system specs are…

  • Windows 8.1 Pro 64 Bit dual boot w/ Arch Linux
  • 16Gb of RAM
  • Intel Core i7 4770 CPU
  • NVIDIA GTX 750
  • 1920x1080
    My graphics drivers are up to date 100%. (352.86 as of 6/19/2015). I would also like to note that I have played the game before and I do have saved data for it. I do not know what update it stoped working because I was unable to play for a while because of school.
1 Like

I figured this out myself. I just needed to manually delete every single stonehearth file instead of leaving the work to steam.


welcome to the discourse @tsteinholz,

glad you worked it out. a clean install (manually deleting everything) generally will fix this problem, im going to close this thread now that you fixed it.