[Res] Can't find templates in building_templates folder

Hey, I just downloaded StoneHearth today, and I came up with a problem. I wanted to delete a template that I made, when I went to the folder, nothing was there. Only the default builds were there. Also, I don’t see the default builds in the game. Can anyone help?

Hi, and welcome!

Are you playing off Steam?

If so, is this the exact path to your build_templates folder?:

…Steam / steamapps / common / Stonehearth / saved_objects / stonehearth / building_templates

I’m not, so my pah is this: Program Files (x86)\Stonehearth\saved_objects\stonehearth\building_templates
I checked it and I only see the default templates, and those templates I can’t see in the game, only my custom templates

1 Like

hey there @Justin welcome to the discourse :smile:

try uninstalling the game, and then reinstalling the game from humble bundle, in the past others have also had problems with the templates not showing up and that was a fix for it.

Okay thanks for the advice, I’ll try it

It didn’t work. I used the installer to install and uninstall it and I tried it 3 times.

I solved my problem. I used the .zip file instead of the installer, and the default templates are there now. I haven’t tested making a custom build yet, but I think I’m good. I think it’s because the files were locked on the installer version, but not on the zip. Anyway thanks for the help and suggestions


Thanks for the feedback. We’ll take a note on this, since several people in the past reported that they couldn’t see the default templates (usually fixed by reinstalling, but not all the times it worked).
Paging @yshan / @sdee

1 Like

I replicated this issue. TL;DR: The devs must make sure the installed version copies the default templates to the folder where the user data is stored (this is the cleanest solution, I think). On the other hand, they could make sure that the data under the program installation is always accessed.[1]

It seems the installed version checks on %LOCALAPPDATA%\stonehearth, but not the “Program Files (x86)/stonehearth” folder. Copying the contents of the saved_buildings from the latter to the former fixes this issue.

This only happens on the installed versions; IMHO this is due to the fact that the steam version is already tied to a particular user (data is found at same place as installation), and zipped version as well, whereas the installer makes the program available to all users.

[1] This would likely make an extension of the current user preferences file necessary, to track the “deleted” templates which are available in the default roster, to enable removing them from the user’s view without physically removing the files from the installation locataion.