Removal of land during construction



Error in building construction
Earth is removed with the floor when using the eraser

Steps to reproduce:

  1. Get an element of the floor
  2. Put on the ground
  3. Take an eraser and remove the floor

Actual Results:

Latest Steam version without mods


Dude… you have debug tools… no mods huh?

And if you used debugtools to remove it thats why


I do not know
But It was not until this moment
Switched on itself?
And I myself did not put fashion
Because I used a clean version of Steam
I think that’s the way it should be


Hmm what do you mean by this? I can’t seem to reproduce it.

But in the past, there was a bug like that.
Is that only road or also ground? I assume the blocks on top of the grass are slabs.


This is the element of the road
Spent on the ground and removed
There was a pit
Before this was not


Press F5, does it remove the hole?
I can’t reproduce it, but if you say there was no hole, and you didn’t start building, this is a regression.



Not so long ago, I had this problem. The problem is that you deleted that with the tool not eraser (from what I gather) If you used the eraser, or any other thing, the solution below works 100% of the time.


To put back the floor as wood tiles, you can use slabs

If you want the ground back, I believe that you can use the tools.

Furthermore, if you used the eraser on the ground, @Relyss please correct me if I am wrong here,but the result would be that it would erase the grass/soil tile. [If this is not possible, I belive that a glitch happened and the computer/ai/code assumed that that was what it wanted]


I had it happen a few times but not noticed any pattern so no luck in reproducing.


He is in design mode. Using the eraser from the building editor to remove road or floor while still in design mode, should not leave any hole. In the past, there was this bug:

But it was already fixed long ago.


Ah, then I do not know what the problem or cause may be in that regard. Probably the game glitched.

Just a quick question just in case, @Cheochenit, was it by any chance that the building was constructed partially there and then deleted by mistake or demolished - In which case, the thing would be a scar of the demolished road.

I know you said you used the eraser but just to be 100% sure - sorry if this seems silly


After restarting the game the pit is gone
I could not test the function of F5
When you try to play this bug again it stopped appearing


Glad your problem solved itself!


I think any problem can be solved by restarting the program)