RE-Place Blacksmith anvil?

so my blacksmith got bugged out, and i tried the whole, move the anvil so the mats on it get picked up(which used to fix it) yet now it doesn’t fix it anymore, so i un deployed the anvil, to try and fix it that way.

now i have an unclaimed anvil in my blacksmiths inventory, with no way to redeploy it. I tried the following:

1)go into item placement, place item on ground, when i click to place it closes the window, yet no anvil is placed.
2)created a floor, followed above, and it placed the ghost of the anvil correctly, yet nothing gets placed after 5-10 mins of waiting.
3) placing it in a house does the same as #2, (now i have 3 ghost anvils to be placed, yet no one places them because it is in the blacksmiths backpack) (i think)
4)demoting him to worker, promoting him back to blacksmith. no change
5)demoting him to worker, promoting other to blacksmith. (no change) and at no time, was i able, in any of the above to create or place a new or existing anvil.

thanks for any help with this, as my only alternative is go on without a blacksmith forever, or restart game. and yes restarting is an easy fix, but who wants easy! lol

i am software literate, if this matters, and if there is a way to place one, with a map editor or whatnot , if given brief instructions i could prolly do it.

ps. i can access the anvil workshop window just fine, by clicking on the blacksmith and selecting open workshop, yet there is no actual anvil for him to do any work if i tell him to.

It might be possible to fix using a combination of the Debug Tools mod and the Console commands.

The way the game assigns a hearthling to a workshop is actually a bit round-about. The hearthling has its own crafter component which points to a workshop entity. When that hearthling places a workbench, it tags that workbench with its own workbench entity.

With the debug tools, you can use the item dropper to drop an anvil into the world. The anvil is designated as stonehearth:blacksmith:workbench. Once it is in the world, you’ll have to see if there is any console command that would let you assign a workshop value that is the same as that on the crafter in question. That might fix it.

If I’m a litte vague about the console commands it is because there are some pretty new things in there and not much is known about how they function as yet. Maybe you’ll figure it out first.

Note: They are planning on releasing a redesign of the crafting workbenches in a near future alpha. With that one, all crafters of a certain type can share workbenches, so you won’t have to assign them at all. That should fix the current problem you are having for the future.

I ran into the issue of my blacksmith not crafting the enhanced anvil or forge. Reloading, and even designating a new crafter didnt fix. It seems evident that it was an issue with the ACE mod and the crafter trying to craft these items UNDERGROUND. I rebuilt crafting stations outside and he crafted them immediately.