Goblin Truce Trade Issue


I created 4 additional blacksmith anvils (not including the one I had first created in the game) placed 3 down as an object and 2 in inventory

though the trading system still says I have only 1



did you build those anvils when you were asked for them the first time or after he returned?

I had 1 anvil before he showed up ( that was the one I would use for my crafting) and I created the other 4 afterwards the crafting panel, all of them was created by one crafter

hm… sorry but from answer it’s not clear for me now if you build those anvils before or after he returned to get his stuff.
so far from my experience any items he wants won’t be counted anymore in the dialog once he returns

I had 5 total anvils. 1 was built before he ever showed up ( that 1 was counted as 1 out of 2 when he first asked for the stuff)
I created 4 more afterwards to get 2/2 count. However the goblin never accepted the anvils created during the allotted time given to hand in.

Does that make more sense?

1 Like

yeah thanks. do you have a savegame from when showed up?
try with 2 blacksmithes the 2nd one crafting the 2nd anvil so it’s “his” anvil. just an idea spooking around in my head.

I had the same thought as well

I did try with 2 blacksmiths afterwards however the results were still the same. What had happened was that crafter 1 ( first crafter) still created crafter 2’s anvil. rather than crafter 2 creating their own anvil.

What I didnt try however was demoting crafter 1 so they arnt a blacksmith anymore and making crafter 2 making the anvil.

I can test that quickly right now if you wish.

1 Like

might be worth a try. if it doesnt work devs will have to look over it, cause that’s the point where i’m out of ideas then.

so even after demoting crafter 1 and creating a new crafter, the anvil was still not accepted.

1 Like

The goblin chief only asks for stuff you already had in your town when he first arrived (not when you first open his dialog box). If you sold some of the stuff he was asking for, he will not accept any substitutes! It’s a bit wierd, but there you go.


that still doesnt make any sense. when I first started, I only have 1 anvil. he asked for 2. I only had one blacksmith.

so that stillgoes against what you said.

Paging @sdee, is this still an issue?

I believe so. Thanks for the report!

unable to give goblin items he asks for
a goblin chieftain came into camp and requested 3 reinforced wood doors. I had 5 in my inventory but it claimed i only had 2 and would not make the trade
Steps to reproduce:

  1. a goblin with a pointy hat walks into camp
  2. asks for 3 reinforced wood doors
  3. unable to give them when he returns

Expected Results:
give goblin chieftain the doors to satisfy him
Actual Results:
unable to give items even with extra in inventory


Versions and Mods:
latest version
System Information:
windows 8 surface pro 3

This is only an issue if you select the “Satisfy Goblin” action BEFORE you have all the required items. What I would expect the “Satisfy Goblin” action to do is automatically schedule any missing items for creation.

Title: Undeployed items are unavailable for the goblin ransom.

Summary: Deployable items, which have been deployed and undeployed again, are not considered for the ransom of the goblin boss.

Steps to reproduce:

  1. Play a regular game (enemies enabled).
  2. Have deployable items (e.g. decorative stuff, furniture, also workshops) ready and deployed.
  3. Wait for the goblin boss to appear. If the ransom includes some of the deployable items, undeploy one of the requested items.
  4. When the item is ready in the inventory, check the “satisfy the goblins” list.

Expected Results: The undeployed item should be checked on the list, and the goblin boss should accept it when he returns.

Actual Results: The item is not considered for the ransom and the requirements of the deal are not met.


The requested pedestal has been set up before, but was undeployed again (not visible in the town overview, I didn’t pay attention, but this was after undeployment). The bronze ingot is recognized, so the requirements are generally working.

This is the placement screen, so the pedestal is clearly in the inventory and not anymore deployed. Apparently the chieftain only wants mint condition, no second-hand stuff…

Version Number and Mods in use: v0.13, release 491, x64, Steam, stock (no mods)

System Information: Windows 10, 64 bit

1 Like

Here is another post with this issue.


Thanks, merged it here!

I’ve tested all the permutations above in our current top of tree build, and I believe that this may now be fixed. If you see it again in a future build, please upload the save and we will take another look!

Update: The chief will only take items in iconic form, so he will not take deployed items.

1 Like

his ransom will still be taken from deployed items.
for example on his first visit he asked me for 4 mean beds -> ordered carpenter to maintain 4 mean beds. yet all mean beds given to him were deployed ones and the ones in storage untouched.
same goes with crafting fine beds/chairs. my carpenter has a fetish for crafting with used beds. i guess both is related.