Rayya's mason workshop cannot be built

Or, by its alternate title -

“Blueprints that Hearthlings will not build, A23 edition: Rayya’s built-in mason workshop template”

Once the outer shell is complete and it’s time to add furniture, the building process stalls out indefinitely. Since the template is shipped by the game, I reckon I don’t need to provide you a template file or savegame for this… =P

1 Like

does this happen on every world or just this specific world?

1 Like

This is the first and only world I have played since Alpha 21. It is started fresh on A23, which is freshly installed. No mods present. I only have 9 Hearthlings and only built four other buildings up until this point. I tried building the mason workshop twice. The first time I thought it had a hangup because the level 3 mason crafting station was missing until I leveled my mason high enough; but the second time around, I had all components in storage and it stalled at exactly the same point.

I suppose I can try making another world and checking if it happens there too…

Alright. i started a new game and built a mason workshop there. It worked fine on the first try.

Then I went back to my other world, and tried to build the workshop for the third time. And, for the third time, it failed to complete!

Here’s the savegame from right after it failed: Dropbox - 1517057421827.zip

Just tear down the stuck building and try to build it again; all the components are present. It simply won’t finish. =/

Alright, I looked and found the issue.

I built a ladder to the hanging piece of scaffolding and once the hearthlings could reach it they completed the building no problem. It’s a pretty common error with the current system but they are working on a new building system so this shouldn’t happen anymore after that (hopefully)

1 Like

Interesting. I tried looking for such problems, but I lack the experience to spot them, it seems.

Ended up force-completing the building so I could get on with my playthrough, but I will use this example to try and help myself if I encounter another building issue. Thanks :slight_smile:

Unfortunately it happens, always check them (first) and if you find one like this that you cant figure out you can always post on the forums again. A saved game and a picture usually help solve the issue pretty quickly. :slight_smile: good luck.