[R393 - Fullscreen] building standalone walls freezes game

Title:
Bug : Building standalone walls freezes game

Summary:
Each time I tried to build multiple standalone-wall-segments in fullscreen mode, my game freezed and I had to kill my OS, because not even alt-F4 or ctrl-alt-del would work.
Doesn’t happen in window-mode.

Steps to reproduce:

  1. Start game in fullscreen mode
  2. select the wall tool from the building editor
  3. build one wall segment
  4. build another wall segment either by pressing shift or placing another wall segment in the same building project

Expected Results:
Creating a continuing wall over more than one segment.

Actual Results:
The moment the second segment is started, the game freezes.

Notes:
Only appears in fullscreen mode. Window mode shows no problems at all. As the game freezes instantly and crashes the OS, I can’t provide screenshots, unfortunately. IMO, uploading savegames doesn’t make any sense, either, as the problem occurred in a fresh game as well.

Versions and Mods:
Stonehearth 0.1.0 (R393) x64 build - no mods

System Information:
Windows 8.1 x64 | Intel Pentium dual core proc | 4GB system memory | Intel HD Graphics

i have this only sometimes when it comes to a wall or a rift ^^

1 Like

The same wall on the same scenario (for example next to a cliff, or on empty plains) makes the game crash depending on the display mode (window / fullscreen) ?

We’ve been having problems recently with fullscreen mode again, but this seems like a different bug. :confused:

Thank you very much for reporting! :smiley:

1 Like

I should be testing that further, but I’m quite unwilling right now, TBH… I don’t want to kill my computer every 5 minutes… But now that you mentioned that, I’m not quite so sure anymore.
I did think I tried this setup in open ground as well, but I’m writing this a few days later, cause internet issues…

So maybe it’s a known bug after all… Will try that…

yeah, that pretty much sums it up.
Still have to check @Wiese2007’s statement, but yeah.

1 Like

i only play in fullscreen with full settings in 1920x1080 xD and sometimes it happens and sometimes not - lately it happens lesser :wink: and it only happens when i have tried to make a wall from rift to wall and wall to rift ^^ i will test it again and make some screenshots when i have time and the system dont crash before :wink:

2 Likes

Interesting.
That’s the same scenario where it first showed up for me.
I built from rift to wall…

Testing right now, no issues on open ground and building to a wall/cliff…
Further tests running.

EDIT: I’m quite confused now. As @Wiese2007 already stated, it comes and goes.
Right now, I have tried everything I could think of in a new save and nothing happens…
A few days ago, the same setup had crashed my OS three times in a row…
Weird.

EDIT 2:
Unable to reproduce anything right now, but I will try again in the future. Setting the game to fullscreen again, so who knows…

1 Like

on openground it has never happens me xD i think there should already an very old thread … i must search xD


http://discourse.stonehearth.net/t/release-206-x64-bugliste/11156

2 Likes

this has happened to me three times now, the os completely locks up and the only thing i can do is hard reset. i don’t play in fullscreen. I can’t reproduce the error on demand. alpha 10_5_10 x64