[r166] Slab buildings limited to one storey

Continuing the discussion from Multi-Story Buildings:

Summary: I tried making buildings out of slab like @coasterspaul’s stairs. They are limited to one storey + one slab above and below, and would not be completed.

How to reproduce:
Create slab building over 8 blocks tall (7 above the surface)

Expected results:
Building is completed.

Actual results:
The building is built up to 8 blocks, including the mined-out foundation layer.

Notes: See the linked topic for more pics. Is this possibly a limitation on the number of blocks per building?

Version: r166

Update: Ugh! Well this is annoying…

I tried to reproduce this with three test buildings:

  1. Large volume slab building (10x10x10 cube with stairs) (Rightmost)
  2. Slabs placed on a foundation layer (laid some floor then built a small spire on top) (Far building)
  3. The building that would not complete above (as a control) (Leftmost)

Here are the results:

  1. Large volume was not a limiting factor in building size
  2. Building on a foundation did not limit the height
  3. ??? Still not building! Why!?!

If anyone has any troublesome buildings, can you add them to this report?

I’ve played around with adding ladders as scaffolding. After a lot of coaxing and ladder placement, the building was completed. The entire problem seemed to be a group of blocks that were unable to be built. looking at my Results picture, they’re the blocks above the bit jutting out above the stairs. (Look at the top layer, they go on top of the block closest to the player.)
I’ll have a look to see what can be causing building issues, though I don’t see why it shouldn’t work when the slab buildings are made layer by layer, 3D-printer style.


Ladder scaffolding confirmed to work. I think the problem here is that slabs are dealt with the same way as floors, although they are obviously different. So the coding will have to be revamped, or we’ll just have to hire some ladder-placing engineers.

1 Like