Question about editing models

I tried to remake the skeleton mob using magicavoxel and voxelshop to fit my egyptian playtrough, but it seems the animation was removed in the process. I didn`t go overboard, it should be able to use the same animations. What did I do wrong? Complete noob here.

How they look in magicavoxel


Head 1

Head 2


Am I doomed?

magicavoxel doesn’t support multiple matrix (same thing as layers in image editing). Voxelshop is fine.
So the objects you save there are all one layer.

You need to have multiple layers so each piece can move independent of the others.

For the animation to work, you also need to name/label each matrix/layer with the correct name, cause the animation will look for the pieces with those names to move.


Thanks, it works now!


I have another question…

When I import qbs directly to voxelshop they don`t stay in the center of the bounding box. I know I can move them, but the process of moving them to the correct spot takes a lot of time for me. Is there a shortcut/hotkey to make them move to the center?

There is an option that exports it centered. (sorry, can’t remember now, it is one of the checkboxes)
Saving in the magicavoxel also center it.

Yes, but magicavoxel remove all layers which take time to recreate.

I found an option to set the origin when exporting as .dae, but not matter what option I select the result is the same.

This is the settings I use, and for centering the object I would guess you need to un-check the Use origin as zero

The exported file will be centered, but you would still see it off-center in the editor, requiring to close and open that file again.


It worked, many thanks!

By the way, you don’t need the grid to have any specific size. (I’m guessing you are using the 31x41x31 recommended in the options) The size does not matter if that option is un-checked. If it is checked though, everything out of the box will be auto cropped/deleted.
I usually set the grid to have the exact size of the model I’m working on. It is easier for measurements.

1 Like

Thanks for the tip, but I tried to export with the boundary box un-checked and this was the weird result -

I don`t know what I did wrong, but I decided to just move the model manually for now