Question about collisions, and how we can bypass them?

I was wondering if anyone knew how to bypass the collision on objects. By this I mean the red X that comes up when you can’t place an object down.

Look at this example.

I’ve created an end piece of the wooden fence. I should be able to place something in between but I can’t. Earthlings also will not pass through this area.

There is 2 lines in the main json file for the object which is:

  "region_collision_shape": {
      "region": [
           "min" : { "x" : -0.25, "y" : 0, "z" : 0.25 },
           "max" : { "x" :  1.25, "y" : 2, "z" : 0.75 }

Does this have anything to do with what I’m trying to do?


If you want to remove collisions, just delete the lines you posted. The item will be placeable underneath other items and it will not prevent anybody from walking through/over it.

Oh, and double check that you haven’t messed up the formatting when you delete stuff from Json.

google JSONlint, it’ll verify for you! :slight_smile:

Alternatively, you can also try the following:

"region_collision_shape": {
  "region": [
       "min" : { "x" : 0, "y" : 0, "z" : 0.25 },
       "max" : { "x" :  1, "y" : 2, "z" : 0.75 }

This will limit the fence piece to one block, rather than 1.5 blocks (centered)


Edit: @phector2004 sounds right. I guess the collision box depends on where the origin of your object is.

I think you need to change the x value here. It looks like a normal fence has it’s origin at the endpost. The collision goes 0.25 voxels in one direction (that’s to cover the post), and 1.25 voxels in the other direction.

Try changing 1.25 to 0.5 and see what happens. I think that should chop it off but I haven’t really played with the collision boxes before so I could be wrong.


Hi @thomasbiggin,

What you are trying to do requires you to place the collider in just the right spot. The game has some debug features which can visual a collider in the game. This should make it easy to get it in just the right spot. :wink:

To enable the debug feature you’ll have to modify your ***“user_settings.json”***, which can be found in the StoneHearth installation folder. folder right before your mods folder

    "chromuim_log_severity" : "verbose",
    "enable_debug_keys" : true,
    "alpha_welcome" : {
  	    "hide" : true

Just add "enable_debug_keys" : true, :slight_smile:

Then in-game press F11 to turn on and off the debug view.

Then do as @phector2004 and @jonzoid have pointed out to change the shape of your collider :slight_smile:


      "min" : { "x" : .25, "y" : 0, "z" : 0.25 },
      "max" : { "x" :  1.5, "y" : 2, "z" : 0.75 }

Seem to be the right settings for me, though I don’t have the models you are working with. The Hearthlings also seem to path through :wink:


Using those coordinates worked. Thank you! :smile:


It would be nice to have a tool which made making the collisions a lot easier. I tell you that.

Instead of making a new thread, I have come across a problem. When I build a house now, only the first layer of the roof is created and then building stops, leaving me with an open roof. Without the endpieces mod the roof is created.

At a loss.

i see there are some functions that i haven´t see until today - do you have a list of functions that i can add to the usersettings - like the chromiumlog change? i think this can help the devs later :smiley:

Some can be found in the code, but most I just steal from when Tom streams :wink:

print screen of Tom’s user_settings.json

There are probably other settings to be found too.

Strange I would doubt it has to do with the mod you’ve added… perhaps just a new bug with roofs…?

1 Like