Placing Doors and Windows

I see now that it was me that misunderstood and did it wrong :slight_smile: Thx anyway

Hmmm… I did exactly as you explained…

  1. place slob without building it
  2. place item window that are built
  3. delete the slob
  4. Click on finished editing.

the thing for me is that I have the “ghost window” on the mountain opening or how to say but the “finished editing” goes away after I deleted the slob
same thing happens with the door
another strange thing is that the “finished editing” appears again if I delete the “ghost window” or “ghost door” but then there are nothing to build
if I only let the window be there where I placed it the villagers wont build because I havnt clicked on “finished editing” that is not there until I delete the window…

It looks like the slob and window is not as 1 building when I am doing it… or they are not “connected” or how to say…
it looks like that the window doesnt count as a blueprint when doing that way

Checking it right now, but you may be right. The change in the eraser situation may be the cause. When you click on it now the building is de-selected. I’ll see what can be done.

Have fun, Kyth.

I think I got it… I havnt tried it yet lol… I build the door or window and then delete the slob because when I selected the door before I deleted the slob the build menu for the door came up after a few fast leftclick on the mouse but not after I deleted the slob… opps I called it slob and not slab…

Ok writing again how I made it…

I did the steps you explained but before I deleted the slab I clicked fast 3 times on the door and clicked the build button and the left thing on the pop-up message to say yes build it or what it say… and after that I deleted the slab before the villagers went there to build it… I did that while the game was paused

Hmm it worked on the door I tried it on when I clicked 3 times… now when I am testing it on the window it doesnt work… I had the door on top of the slab … I will test to have the slab in front of the door and see if it happen the same

It seems now that if you delete all the slabs the hearthlings are no longer able to build the window. You will need to leave one slab somewhere in order to re-select the building and get a working build button.
So, find a spot where you don’t mind having a slab, a hole in the wall or in the floor for example. Connect it to the window hole in the usual fashion. Place the window and delete the connection to that slab. Select the slab to get the build button back and click “build”.
Relyss’ mod slabs with terrain colours may be of help with those offending last slabs.
Slabs with terrain colours

I hope this helps, Kyth.

did you read what I said ? :slight_smile:

In case you are building a whole free block wall you need to include the windows in the wall before it is built. The wall itself serves as the last slab.

Have fun, Kyth.

I’ll try that too. lets see what happens. :wink:

Hmm I accidently deleted the wrong message…

or I cant see the hahaha message

What I wrote so other can see what I deleted was something like this:

Hahaha no need Kyth… Just click like crazy on the door or window it works :smiley: before and after the slabs has been deleted


When it was only for testing a guy came after a few seconds and wanted me to give him 6 wooden swords and he would give me 2 bronze armors after 3 days…
I thought… “Cool” :P…
What I didnt thought about is that the merchants are random and thought that the same guy would come when I reloaded the save… gah :smiley: I am in the beginning and havnt made any armor yet…
I reloaded instead of console and destroy…
Had to destroy or reload because I tested this on the ground where I didnt wanted it to be anything and I choosed the wrong option :smiley:

I forgot to say that you have to leave the edit window before clicking on the window or door like crazy …click on the harvest icon or something

Confirmed! If you click like mad on the window the build button comes back. You can then click on it and the hearthlings will build the window… funny!

Have fun, Kyth

1 Like

Ok here is my steps…

  1. click on the build & design button

  2. click on design building.¨

  3. place a slab on the ground or wall or on another item that you have made (dont click on the finished editing)
    (If you are going to put a window or a door on a wall you need to look at the pictures that shows how to place the slabs that Kythandra showing at the top of this thread but dont follow the steps only the slab pictures and then come back here.)

  4. Click on “Place Item” button… NOT the furniture (chair) button like someone thought earlier in this thread :smiley:

  5. select window or what ever you want to place. (You need to have the items built at the carpenter or mason bench)

  6. place the item on top or the front of the slab or where ever you want the item… (Dont close the place item window)

  7. This step is little bit tricky so read this step carefully if you want to succeed
    Sometimes the item disappear or choosing the slabs when you are doing this step so be careful…
    if your item is wooden diamond window and your slab is made of stone it will show both window and stone if you are doing it correctly…
    your items in the stockpile or chest wont disappear if your ghost item do it.
    They will only disappear from the stash when the villager is taking the item to put it on place
    Now for step 7
    click at the corner of your ghost item area (square) 2 - 3 times. (half of a second between the clicks) and click on “build” in the new window that pops up that is called “Building designer - Building no …”

  8. click on the “ghost slabs”

  9. use the eraser and delete the slab or slabs

  10. close the design building window

  11. unpause the game and watch the villagers build what you wanted them to build :smiley:

If they dont build that you want them to.
Do the steps again or there might be a bug or something that has been changed in a future patch that makes it impossible

1 Like

Changed the first post to add the new process. Credits to you @Roggah :wink:

Have fun, Kyth.

1 Like

I like to help and tell other what I did to make it work so they dont need to rip their hair off from the head because they getting crazy because then they will look like me :smiley:

Bald but not because of ripping my hair off :smiley:

1 Like

I have edited my steps alittle so it bacame more understandable or how to say… I am a tired Swede that needs to go to sleep thats why I forget some words… :smiley: but I will keep on playing little bit more… Guess I will be tired at work tomorrow :)… 11:55 PM now

1 Like

Thanks for showing this Kythandra i just uploaded a video to spread this :slight_smile:

1 Like

something is wrong with the forum…

I am trying to write new steps and when I am writing the steps as numbers like step 1 and so on… it comes back the same number like 1 2 3 4 1 2 3 4 instead of 1 2 3 4 5 6 7 8 like I wrote it … hmm strange …

I wanted space between the meanings or what it is called but then it started from number 1 again